Problem with MIDI channels when using Halion as VST inst.

Hi guys

If I use Halion in stand-alone mode, everything works as expected: I have some slots/instruments in the rack, each one on different MIDI channel, and when I change the MIDI channel on my keyboard/controller, the slot that’s set to that channel will play.
The problem starts when i use Halion as a VST instrument on a MIDI track in Ableton. So I put Halion on a MIDI track, I set it to receive MIDI data from my controller, BUT no matter what input MIDI channel i set on that track, Halion will always play the slot on channel 1. For example: I set my keyboard to send data on channel 3, I set my MIDI track in Ableton to receive data on channel 3 (or All channels), but Halion plays the slot/instrument that is set to channel 1 and not the one that is set to channel 3. It’s like Halion receives data from any channel but only transmits it to the slot that’s on channel 1. Why is that?

Thank you

I don’t have Ableton but I guess you don’t have to change the INPUT channel, but the OUTPUT channel of that MIDI track.

The channel you set on your keyboard controller will be probably replaced in Ableton to match the output channel you set on the track. In Cubase there is an option to set the output channel of a MIDI track to “any” instead of a fixed number, so the input channel coming from the controller is not changed. Check if a similar option is available in Ableton.

Thanks for your reply
Unfortunately, as far as I know, you can’t do that in Ableton. If I load a plug-in on a midi track all I can do is set the midi in device and the midi in channel (here I could set “all channels”), but no matter what I set, Halion will continue to play only the instrument that is assign to channel 1. :unamused:

I attached a print-screen so you can understand exactly what I’m talking about. As you can see, I set my midi IN channel in Ableton to 11, i set my keyboard to send notes on channel 11, BUT Halion plays the instrument on channel 1, and not the instrument on channel 11. I could set the midi IN channel to “all channel” and I get the same results.
Maybe this has to do more with Ableton than Halion. :confused:

You have to set the INPUT and OUTPUT to the same channels in Ableton, I’m afraid there is no other way of doing it.

Well, you could do another thing, a bit more extreme:

  • Create a midi part for every channel you need in Ableton, and assign a different MIDI INPUT channel to each of them.
  • Use a different instance of Halion for each channel, with only one sond on each.
  • Set the monitor input on all the midi parts (don’t know if that is necessary in Ableton, but it would be in Cubase).

Now when you play something in your keyboard, only the part with the same midi channel will sound.