Problem with midi Cubase LE AI Elements 10

Hi! I have recently purchased a Millenium MD-90 e-drum. The problem is that Cubase LE AI Elements 10 detects it and receives input when I hit it, but it does not output signal, so I cannot use it with any vst or plugin. If I use the e-drum in standalone version (addictive drums, for example) it works outside of Cubase10. So I discard that it is the e-drum.

I have reinstalled Cubase10 without success. So I tried an older version, Cubase 5 and it works perfectly. Just plug and play.

I have to say that I have checked the inputs and outputs, the channels, everything is activated. With a normal midi keyboard (Keystation mini32) and I don’t have this problem.

Can you help me, please? I need to work with Cubase 10.
Thank you

Hi and welcome on the forum,

If you try to record the data, are they recorded? If yes, make sure, it sends the MIDI Notes your VSTi expects, please. Sometimes, there could be some octave shifts, for example.

Hi! I downloaded the Cubase elements 11 demo and it worked. So I uninstalled it and then bought it and it doesn’t work anymore. The same thing happens to me as with C10, a signal comes in when I hit the e-drum but it doesn’t sound. It doesn’t even record the hit.


Absolutely sad to have bought 11 if it gives me the same problem.


Please, double-check, the MIDI Notes, if you send the expected one.

Also double-check the Preferences > MIDI > MIDI Filter, if the MIDI Notes are not filtered out, please.

Hi Martin!



Yes, this is OK.

Could you please try to record the MIDI data? Just to see, if there are MIDI data, but they don’t trigger any sample, or if there are no MIDI data recorded at all.


I think the problem has been fixed. I’m not sure how it was, but I think I have enabled everything in midi filter and then restored by default. Then I read your last message and when I click the rec button, everything was working, it has captured all the hits and my edrum is already working in cubase !!

Thank you very much for your help. You don’t know how many hours I’ve spent trying to fix this and how many forums I’ve consulted to fix it. Amazing!!

Have a nice day :slight_smile: