Problem with midi filter in Cubase elements 10

I’m trying to use an expression pedal with impulse innovation and cubase elements 10.
The pedal rises and lowers all the volume in output while I’d like to regulate the volume of just some channels that I selected in Cubase.
For example : I have in channel one a piano, in channel two a violin and in channel three a cello and I want to rise and lower just the violin and the cello but I don’t know how to do it. Since the command in my controller is global the controller manufacturer suggested to use the midi filter in Cubase in order to ignore the pedal signal in just some channels. Could someone help understand if that is feasible in my cubase version and if yes how I could do it?


The MIDI data go to the MIDI/Instrument Tracks, which are Record enabled, or Monitored. Make sure the only track is Record enabled, or Monitored, please.

Do you use dedicated tracks for every single MIDI Channel, or do you use only one track for all MIDI Channels, please?

Thank you for your quick reply.
For every channel I use a different Halion SE instrument but I don’t know how I can check if I’m using a dedicated track for every midi channel or just one track for all the midi channels.
Could you help me understand how to perform the check?


Then I expect, you are using only one instrument/patch for every single (Instrument) Track.

Do you have only one track Record Enabled and Monitor enabled (if any is Monitor enabled), please?

Unfortunately yesterday I had to return the expression pedal but I should get a new one the next Wednesday to make new attempts. In respect to your question, when I tried, both Monitoring and Record were disabled for every track. Could that be the problem? If so, should I enable for some of the tracks Monitor or Record? For which one? Thanks


You should enable the Record for the only one track, where do you want to record to.

as soon as I have the new pedal and I have a little bit of time I’ll try out your suggestions (hopefully in about a week) .
Thank you so much for now!


if I enable “Record” only on the track where I want the pedal to have the effect, I can’t hear the other tracks.

So in the following configuration the pedal affects just Warm Pad but I’m not able to hear Organ and Ensemble Strings.

In the following configuration I hear the 3 instruments but the pedal affects all the instruments.

What I’d like to get is to hear all the instruments with the pedal that affects just warm pad.

Do you have other suggestions ?



Double-check the Constrain Delay Compensation is disabled, please.


I’ve double checked is disabled…


Do I understand right, you have some MIDI data recorded in the track, but you don’t hear it while playback, right?

Maybe I didn’t make myself clear.
The problem is related with the expression pedal.
If I create for example 3 tracks and I assign the pedal to just one of those, I see the fader of the cubase mixer moves on just the one I selected but the pedal affects the sound of all the 3 tracks.
The controller manufacturer told me that I could solve the problem with cubase midi filters but I don’t know how to di that…


… I don’t know also if such midi filters are present 8n my cubase version (cubase elements 10)…

Try to disable any MIDI Input on the Piano track, that you don’t want to be affected by the pedal.

If that does not help…
Can you tell us which MIDI data your pedal sends? Is it MIDI CC #11?
Are all tracks only affected during recording or also during playback afterwards?

Can you please post screenshots of this part of the Inspector for each of the three tracks?


to make things easier I ‘ve done the test with just 2 tracks (acoustic piano and string ensemble, I’ve assigned the pedal to only the String Ensemble).
If I disable any MIDI input on the piano track unfortunately it stops the sound. So I’m not able to play the piano through the keyboard controller (I want the piano track not to be affected only by the pedal).
The address of the MIDI pedal is 11 (see attachment below for the configuration)

During playback it seems that the 2 tracks are recorded correctly but again when I lift the pedal I stop hearing the sound of both the tracks also in playback (tough it seems they are correctly recorded)

Pedal down (I can hear the full sound) I’ve lifted the pedal Pedal up (it seems correctly recorded but I’can’t hear any sound also during playback with the pedal down)

Here below you can find the screenshot of the acoustic piano inspector :

Here below you can fine the inspector of the string ensemble :

Do you have any other suggestion ?


I am in the process of learning your setup to find a good solution for you.
I see that you setup a MIDI Remote Device for your foot pedal. I am not sure that is even necessary. Usually the pedal sends a certain type of MIDI message, usually a continous controller (thus CC), when it is being operated.

In your case you want to have live input on both tracks (as per your last example) simultaneously, but only one should react to the pedal. The other should not.

Question: Are your MIDI keyboard and your pedal connected to different physical MIDI inputs?

I connect the pedal to the keyboard controller through its cable and the keyboard controller to the imac though an USB cable. So there are not other midi devices.


Yeah, I thought so. That’s too bad as a seperate connection would have been the easiest solution.

The advice of the controller manufacturer to use filters sadly does not apply to your version of Cubase. This starts with Cubase Artist and higher.

You can try to have the pedal change the volume of HALion SE instead of the volume of the track where HALion SE is loaded to:

  1. You would need to deactivate the Remote Device by changing the MIDI in and out to “not connected”.

  2. On the track where you want the pedal to work, open HALions interface

    Go to the “MIX” tab and right click the Level slider for the loaded instrument. Select “Learn CC” and then use your pedal. Now the Level slider should move as you move the pedal.
    Unfortunately you need to do this for each instrument individually that you want to control with your pedal.

If you want to use this method you can record the pedal movement within the MIDI part as CC#11 just by the normal recording procedure.


following your suggestions below :
I can see the level slider moves as I move the pedal but unfortunately the pedal still affects both the tracks though I selected the “Learn CC” just for 1 track.
I guess probably the only solution if I want to use the pedal as I intend to would be to upgrade Cubase to Artist or high versions…

Thanks in any case for you help.


Did you follow my step 1 - to disconnect the MIDI remote thing completely?