Problem with Naming scheme for Selected Clips

Hi!

I’m having problems getting a Naming scheme to work correctly when rendering Selected Clips.

The naming scheme looks like below and is meant to add “Trackindex0X” and “CdTextTrackTitle” as name for rendered Clip in specified folder.
The new folder works okay, it gets named using “CdTextTitle” and “CdTextDiscID”, but all I get is a file name that is: " - "


When using the same naming scheme for “Selected CD Track” (or “All Regions/CD Tracks”) it works okay, and I get both Track index and CD Track Title from CD Data.
So I can use that instead but I thought it would work in the same way for both CD Tracks and Clips, they are in the same montage with the same CD Data.

  • So it seems to be some problem when trying to use some Auto Variables when rendering Selected Clips!?

  • In addition to this, the metadata in the rendered file (in this case Mp3) do not contain “Track title”, as this is also meant to be taken from “CdTextTrackTitle”.

  • I also noticed that when Rendering Selected Clip again, with same name, WL doesn’t warn about overwriting previous rendered audio file.

Anyone else having these problems?


Regards
/Hackej

Selected Clips are not CD tracks. CD tracks by nature can have slightly different lengths due to markers being offset slightly from the clip bounds which is pretty normal in my opinion.

I have never rendered selected clips, only CD Tracks so I have precise control over the extra space before or after the actual clip length to control the actual “CD Track” lengths.

Hi Justin!

Yes, I agree.

But the thing is that you can use some of the CD Data in the naming scheme for Selected Clips, such as CDTextTitle and CdTextDiscID on album level, so I assumed (or hoped :wink:) that there was a way to associate the actual clip with the actual track and CD data and get it to work.

But maybe that is not possible.
And all these small differences makes it sometimes hard to understand what is possible and not possible. :confused:

Otherwise rendering CD Tracks works OK.

/Hackej

Justin is right: “Selected Clips are not CD tracks”. The context for selected clips can’t inherit stuff from a context with CD tracks.

Hi!

Thanks for replies both of you.

I will render CD tracks instead.
Just trying to get a grip of all the details.

/Hackej

If you’re mastering singles, EPs, and albums, I think you’d always want to render CD Tracks because as mentioned, to maintain the spacing between songs and a slight buffer between the start of the file/track and the first downbeat or sound, you may want to have a slight buffer (200ms or so) between the start marker and the first sound, and however much digital silence is needed after the song to maintain the correct spacing until the next song starts up. If you render only the clips instead of the tracks, all that becomes more difficult or impossible.

Hi!

Just some additional thoughts…

As I am doing the whole workflow, from recording and mixing in Cubase to processing and mastering in Wavelab, I have taken care of most of the start and end fades and silence in Cubase already.

So quite often I initially i just want QUICKLY to try out various processing and then convert and render individual files (or set of files) for further listening. This before deciding and configuring final order, possible additional fades/crossfades and processing of final album/CD.

That’s why I previously have worked with primarily individual audio files or set of clips in an Audio Montage.

But as mentioned, I can do that with CD Tracks as well, if/when I want rendered files to use Track data in any way.

And yes, Selected Clips are not CD Tracks, but Selected Clips “know of” corresponding CD tracks!
When you select a clip in the montage window, the corresponding CD track is highlighted in the CD window, and the corresponding source file is highlighted in the File tab as well.

So there must be some kind of relationship between the Source file --> The Clip --> and the CD track!?

And, if so, when rendering Selected Clips you should (logically) be able to do the same thing, i.e. from the Clip find the CD track and via it find relevant CD Track data to incorporate it in the rendering process.

That was what I assumed, or hoped for, anyway.

/Hackej

I think you are right that clips that are part of a defined CD-tracks should ‘know’ about the metadata used for that CD-track, but then, why not simply use ‘Render CD-tracks’? Otherwise things can become complicating.

As an example, I’m thinking of a not uncommon situation where a CD-track is built up of several clips - a separate intro for instance that can be precisely positioned/ crossfaded in WL. When using ‘Render selected clips’ this becomes tricky: if I add both clips, it would result in two rendered files needing the same name.

Hi Arjan!

Yes I agree.
In such situations it would/could be a mess, and rendering CD tracks is the only option.

It’s just that it took me quite some time to realise that CD trackdata is not available by design for Metadata presets or naming schemes when using Clips. It’s not obvious for “new users”. :slight_smile:

But as said, I will use Render CD tracks instead.

/Hackej

I often have one clip which is several CD tracks, which also breaks the idea that clips and tracks kinda correspond.

Paul

Are we starting to talk about two different things now? CD/Album Tracks and Audio Montage Tracks?

Audio Montage Track FX are what I pretty much never use.

I can confirm that the Scheme, under the Audio Montage render tab, does not pick up all CD-text info, like Track Title etc. if inserted using the CD tab → Edit CD Text. However, rendering the exact same Audio Montage but through the Master Section, does work. Rather strange, as they both have the same controls for exporting , let’s say ‘All Regions’ → ‘CD Tracks’. I’m not sure there’s a thought to this though.

Not sure what you mean, because rendering is always through the Master Section.
Well, actually there is a “bypass master section” option, but it does not make a real difference.

Please describe more precisely what you mean.

Thank you for a fast reply!

When having a montage open, there’s the Render tab under the Audiomontage workspace. After setting song titles etc. with CD-text and setting the Scheme under that tab (specifically under Audiomontage), and clicking Start rendering, the scheme does not pick up certain CD-Text entries.

However, when using the same procedure under the Mastersection, ie clicking Render (here it’s not named Start rendering), the scheme picks up everything specified under Edit CD-Text.

In both instances I’ve selected:

Auto Select Source →
All Regions →
‘CD Tracks’ →
Render

Please excuse me if this is actually how it’s supposed to work. I see the same functionality when rendering from both Audiomontage and Mastersection so I thought they would work the same. That might be a miss from my side.

It could be helpful to post a screen shot of your CD Tab as well as the Markers Tab in your montage.

Where are you checking to see this info? Where is it not “picked up” and visible?

I see what you mean now. This being said, I can’t see a difference.
Please give me info about what your name scheme is, and also, about what you render.

The scheme works when rendering through the Mastersection, but not from the Audiomontage tab. Since the scheme functions are laid out the same, this leads to some confusion. Basically this is what happens:

  1. Make an audio montage with X songs
  2. Use Edit CD-Text function to create CD-text metadata
  3. Use scheme to set naming scheme (in audiomontage tab)
  4. Render files from Audiomontage tab
  5. Repeat process but render files from Mastersection

The results will yield different results where CD-text data is only read correctly when doing this process from the Mastersection. I’ve attached a PNG which might make it easier to understand what I mean. Thanks for taking your time to read this! /Matt

Answer to reply below this post (I’m a new forum user so can’t reply more than three times, more Steinberg weirdness…)

Good to hear it works on your system! My render including proper naming scheme from CD-Text only works for Mastersection not ribbon. The only real logic here is that if the scheme fails to show the metadata in ribbon, so does the render naming. It’s not a huge deal for me, I’ll just use Mastersection from now on. Thank you for testing this out!

I tried your config:

  • same valid results both for Master Section path or the ribbon path
  • the preview field is not complete, but the rendering names are all valid.
1 Like

Good to hear it works on your system! My render including proper naming scheme from CD-Text only works for Mastersection not ribbon. The only real logic here is that if the scheme fails to show the metadata in ribbon, so does the render naming. It’s not a huge deal for me, I’ll just use Mastersection from now on. Thank you for testing this out!