Problem with Playing Techniques (or is this Playback Techniques?)

Hi, I’m working on a piece for string orchestra and solo violin. I use VSL Synchron Strings Pro and VSL Synchron Elite Strings and Cremona Guarneri violin . I created in all orchestral parts more voices, so that I can use Strings Pro for unisono and and Elite Strings for divisi parts.
I discovered some problems with the Playing Techniques.
A good example you find in the file that I send with this message.

Staccato is not always recognized.
Solo violin: I made a dedicated extra PT for staccato, the only way to trigger staccato samples, the staccato dot is not recognized as playing techniques, the notes have a 50% length.
Violoncelli and Double basses: they don’t recognize staccato notes as playing techniques (but the notes don’t have full length but 75% instead of 50% length, weird…). The orchestral violins and violas do recognize the staccato note as playing technique.
The double bass has no independant voice playback, the violoncello has independant voice playback. Any help is very welcome. I use Dorico 5.0.20
example bad working playing Techniques.dorico (1.2 MB)

After this message I did some more tests in the orchestral violins in the different voices, but there is the problem the same as with the violoncelli and the double bases.

YES!! In the meantime I found the solution.
Until now I wasn’t aware of this behaviour of Dorico, but I found out, and it works like a charm.
My discovery was, that a note needs to have only a limited length to be detected as a staccato Playing Technique.
So if a staccato note isn’t detect as such, I have to go to the key editor and shorten the notes so much as is needed to be detected as a staccato Playing Technique.

@Lillie_Harris I tried to find information about the staccato issue, I described above (a note needs to have a limited length to be recognized as staccato playing technique).
Is this issue documented? For me it was a quest to figure this out.

Ok. And at the end I discovered in the Playback options a new feature, what causes the new behaviour with staccato notes. I send here a screenshot for other fellow users, who perhaps also did not understand this well when listening to the video about Dorico 5 (Janus corrected me, it is Dorico 4). By clearing the white box the old behaviour appears again. Sorry for this “one man chat” …

This option arrived in Dorico 4

OK, thanks.