Problem with printing "All Pages" after printed with "Page Range"

Subject is a piano score with two pages. Some time ago I selected “Page Range” set to 2-2 to only print page two, layout was Full Score.
Today I switched back to “All Pages”. The result (still in Full sore) is now that page two stays on top followed by a blank page and what was (title)page one appears now as page three.
I can’t find a way back to normal page-order in Full Score. The Piano - Layout doesn’t show this behavior.

It sounds like maybe you also have booklet, spreads or 2-up printing chosen as well – try setting the job type back to ‘Normal’.

Job Type was always set to normal. However, when I change it now, Normal and Spreads show the wrong page order while 2-up and Booklet show the correct page order.

Perhaps you could attach the project here so we can take a look?

Hi Daniel, instead of posting the project here I have send it to you via email, I hope that was okay. Thank you for investigation!

Thank you Daniel, problem solved!