Problem with recording midi drums in Cubase 12 pro - playback out of sync

Hi everybody!

I’m new on this community but not a total newbie with Cubase.

I’m encountering a strange problem with Cubase 12 pro. The problem surfaced 2 weeks ago. Before that, all was normal.

When recording drums with Superior Drummer 3 in my Cubase 12 pro, the recorded midi track has a delay. When I’m recording it, and drumming, everything seems to be normal and sync, but in playback my recorded drums are quite a few ms ahead of the rest of the tracks.
They are out of sync.

I played around with different Asio settings and also added ‘Asio Latency Compensation’ to the Superior drummer track, because I read this in another topic. It doesn’t solve the problem.

I’m using a Steinberg UR22 USB audio interface.
My PC is a Windows 10 system with 64GB ram, working with an AMD Ryzen 9 3900 12 core proc
That should not be the problem. There is absolutely NO latency, NO disk overload, and hardly a millimeter of bar in the Audio performance level.

Current ASIO settings:
Yamaha Steinberg USB ASIO
Device: Steinberg UR22
Mode: Low latency
Buffer Size: 192 samples
input latency: 6.893 msec
output latence: 6.871 msec
All on 44.1 kHz.
Yamaha Steinberg USB Driver V2.1.6

Like I said, it actually started a few weeks ago. Before, I have never encountered any of such problems. I’ve updated everything. i can update.

Thinking about reinstalling everything (not windows though) but first trying asking for help here.

Edit 1:
To check if it isn’t my UR22 that is broken or somehow causing it I tried to record drums using my Arturia Keylab49, playing with my fingers. Same problem occurs.

Thanks in advance for any usable suggestions.


There’s this: MIDI not lining up - SOLVED

1 Like

Hi Reberclark,

I’ve followed your instructions, with the hope that it will solve the issue. The thing is, it helps, but now the ‘not lining up’ is just a littlebit less worse. But it still exists.

I don’t get it.

I even tried it in Cubase 11, which is also still installed on my system. The weird thing is, the problem exists there too now.
I did get a certain error message when I started Cubase 11, it said something like:
‘Error in VST midi setup Repais Yes/No’.
I said yes but like I said, the problem was present in Cubase 11 too…

I’m at a loss…

Hi @Peter_Brinkman

Peter, Sorry this didn’t work for you. Believe me I am no expert. I hope someone here will find a solution. Hang in.

1 Like

What i’ve done in the meantime with the help of a friend who uses the same Cubase 12 Pro version:

Checked all Asio settings, are simular to my friends settings, yet the problem consists.

Now I have removed / uninstalled all my Cubase versions. Then did a reboot, including all available Windows updates, and after the restart a reinstall of Cubase 12.

But no, the problem still exists.