Problem With Recording MIDI tracks

Cubase artist 8.5.30 has just thrown another curveball at me. :imp:

If I set up either a MIDI track or instrument track, I can play a VST connected to it via my MIDI controller (via MIDI in on a Focusrite Scarlett 2.4). When I record though, although I can hear the VST, no MIDI data appears in the Piano roll.

If I look at the MIDI event list, the data is there but instead of a note starting at, say, 4.whatever, it shows the note starting at 1870.whatever!

Can anyone help - I am not aware of any settings being changed before it started behaving this badly.

All I want to do is record some music :cry:

Thanks in advance.

I’ve noticed that some forms of recording (i.e. the Independent Track Loop) cause the cursor to loop in the key editor – as you’d expect. Meanwhile, the cursor in the project continues to march off into the horizon. Perhaps it’s something like that? Notes should always be inserted at the project cursor (assuming record enabled and all the other normal conditions are met). The position of the cursor is always shown on the transport panel, so it’s easy to check.


thanks for the quick reply. When you say, ‘project cursor’, what do you mean?


The vertical line in the project window that moves when you hit play or record, page 1133 of the operations manual.

No, that tracks normally drawing the midi ‘roll’ as it records but your reply suggests that the midi event list showing notes at 1800.x.x.x and further shows that Cubase ‘thinks’ the cursor is over there.

How do I tell Cubase to reset to zero bearing in mind I’ve restarted and that hasn’t resolved it.

Many ways to move the project cursor. Shift+B (back to previous marker) or button on transport controls (perhaps multiple times), or edit the value in the transport panel time display, or click on lower part of ruler at desired location (the crossed arrow mouse tooltip should be active at the time, not the pencil, which sets locators).

The project cursor location is saved when the project is saved.

Thanks Colin, I will try these tomorrow.


Trying a different midi interface didn’t exhibit the same problem. The project cursor reported starting at zero but the recorded MIDI data showed that events were now occurring at 4000.x.x.x!

However, going into the box to manage midi interfaces in Cubase, deactivating and reactivating the Focusrite midi seems to have fixed it for now.

Thanks again for all the help Colin.