Problem with script execution via app shortcut on Mac (maybe not Dorico specific)

Dorico 5. 0.20, Mac Studio M1, macOS Sonoma Beta (yes, I know!)

I have a script “Systemumbruch” which creates a system break (in write mode).

I assigned an app shortcut in System Preferences.

Pressing my shortcut “Shift-Ctrl-S” executes the script only after I open and close script menu.

Execute script

I had the same behavior under macOS Ventura.

Maybe somebody can help me solving this mystery.

Dorico doesn’t really work with system-level shortcuts assigned in System Settings (née Preferences), I’m afraid. I agree it would be nice to be able to assign key commands to specific scripts directly via the Key Commands page of Preferences, and perhaps this is something we’ll be able to add in future.


I don’t know what to guess about this, because it works for me (in 4.0 under 10.14 Mojave). Have you tried a different key combo, in case ⌃⇧S is in use elsewhere? By the way, you can remove the switch to engrave mode from your script and the system break should still work.

Edited my script (removed the switch to engrave mode). Thank you for the hint, Mark.

And I tried the following: moved the script from my subfolder “Layout” to the root folder “Script Plug-ins” and now it works like a charm! Scripts in subfolders seem to cause the trouble.

I’m happy again :wink:

It would be really cool to have the possibility to define key commands to execute specific scripts.