Problem with slash notation and rests

I have spent hours searching online this morning and in the forum but I cannot find out how to fix my problem.

I am using the latest version of Dorico 2, working on a jazz chart. Screenshot 1 shows the part layout I am trying to re-produce. The solo part has a rest on count 1 then slashes, this continues with various quarter and half rests throughout the solo.

It’s easy enough to enter in Dorico 2 of course as seen in screenshot 2 but when I move the slash region to get the rest on count 1 then Dorico essentially removes a beat from that measure, screenshot 3, making it 3 beats long as seen in the part in Dorico 2, screenshot 4.

It is my understanding that the default behavior of Dorico2 is to pad the measure with rests unless those options are changed in the panel on the bottom, which they are not. Screenshot 5.

I am almost sure that I am just doing something wrong or missed something but this is the one thing I have not been able to find a solution for in an online search or the forums. Perhaps it is a bug, I don’t know if anyone has this problem or if it’s simply as easy as quitting and restarting (nope).

Guess I could only add 3 screenshots, hopefully I’ve described the problem clearly enough.



screenshot_1.jpg

Can you at least attach screenshots 2 and 3? I only see one screenshot here…

I got the other screen shots to add, hopefully I can add the others to this reply.

Thanks!
screenshot_5.jpg
screenshot_4.jpg

You have to create several individual slash regions. For screenshot 1 you need three slash regions.

3 slash regions for 4 bars? Please explain further, how would you accomplish that?

Thanks!

I tried creating a slash region for bars 43 and 44 in the screenshot 1, then a separate one for bars 45 and 46. However the problem still persists…when I move the handle for the slash region to start on count 2 there is no rest on count 1 and it still disappears essentially turning it into a 3/4 bar.

This is what I get by default:


Seems like you have changed some settings to hide the rests? What about the last note before this passage. Is there perhaps the “End voice” property set?

First of all, thank you for your help, it’s always nice to talk to helpful people!

The ends voice property is not checked. I don’t remember changing any settings to hide rests but I will look everywhere I can think to check.

Your example is exactly as I expected it to behave. I’ve tried re-setting rests to factory default, no difference.

I have uploaded the score to my Dropbox if you wouldn’t mind taking a look. Link is here:

https://www.dropbox.com/s/as1l0v3qhky4fk5/Don't%20Let%20the%20Sun%20Go%20Down%20On%20Me%20-%20Flow%201.dorico?dl=0

Again, thanks very much for all of your help!

Just had a look at your score:
I get the same result as you. No rests. But, when I swtich on the end rest property in Engrave mode, the rests appear. That is definitely not the behaviour I would expect. Perhaps Daniel or someone from the team could have a look.

Did you enter the score in Dorico or did you import the score from XML or MIDI?

I entered the score from a default big band template in Dorico.

This is a bug, Kevin. Sorry about that! It’s already fixed ahead of the next minor update, but for the time being you’ll need to employ a workaround. Use O to engage Force Durations, use , to engage rest input, then set the duration to quarter and input a rest (e.g. type Y) at the start of those bars, then use Remove Rests to remove the redundant remaining quarter and half rests that will appear in the beats occupied by the slash region.

Thanks you very much for responding Daniel, following your directions I was able to get the desired result. It’s only 24 bars or something so not a deal breaker, my focus was on why I couldn’t get it to work. I find it’s usually user error and I figured it was this time also. I know it’s a work in progress and sometimes one little bug will escape.

Please keep up the fantastic work your team is doing (adding jazz articulations?) and have a great day!

Still getting this bug - I’m attaching gif
(was able to use workaround)
music error.gif

This isn’t the same thing, johncrev. You need to make sure you extend the slash region so that it “covers” the range of the half rest; the slash region itself won’t cause rests to be created in other voices.