Problem with (SMuFL)

Hi all,

When I’m copying Ben Johnston alterations (Recommended ligatures) in Word, it gives the wrong accidentals. I’m wondering what I’m doing wrong.

https://w3c.github.io/smufl/latest/tables/johnston-accidentals-just-intonation.html

Best,

Francis

Can you give specific examples? Are you actually using the component glyphs to create the ligatures, or just pasting in the glyphs from the smufl website?

I’ve just tried

  1. Setting my Mac to use the Unicode Hex Input keyboard layout.
  2. Opening word and typing Opt-E262 Opt-E2B5 (without the space).

Even though I’ve told Word to use Ligatures (which it won’t, by default) it doesn’t seem to use them - it just puts the glyphs next to each other.

Select the text in Word and copy and paste to a new Apple Pages file, and - without touching anything else - Pages displays it like this:

I suspect the problem is with MS Word. I would have thought that a quick Google should let you know whether it’s possible to get Word to deal with ligatures properly or not.

Word certainly should deal with ligatures correctly once they are turned on. I ran into that myself recently, and it has always worked as expected.

I copied the glyph of these two :

and it gave me this :

Capture d’écran, le 2021-04-02 à 13.08.31

I don’t really know how tu use the Unicode. I added a Unicode keyboard, but do I do after?

Thank you for the reply!

From System Preferences > Keyboard > Input Sources, tick the Show Input menu in menu bar option. That way you’ll get a nice dropdown like this:

Once you’ve set Unicode Hex Input from there, go into Word, set the font to Bravura Text, then hold down the Opt or Alt key and type e2b3. That should give you a flat. You can now release the Opt/Alt key. Then for the flat, you can type it immediately after Alt/Opt-e2b3. Alt/Opt-e260. You don’t need a space or an underscore.

If you do this in Pages, it seems to work correctly. If I do this in Word, it doesn’t - I’m not sure why.

Thank you! I got it. It’s not working on Word though, even if I activated the ligatures in the font options…

(toutes = all)