Problem with "Staff Size" and "Make Into Frame"?

I’ve been noticing that I am often, but not consistently, having an issue with how both “Staff Size” and “Make Into Frame” work, or rather, don’t work.

For some reason, sometimes they just won’t work as expected and I can’t figure out why.

Take the current file I’m working on. It’s seven systems with two measures on each line, excepting one which has three and one which has four measures. I created it using the default Lead Sheet without any size adjustments in preferences etc. These should easily fit on one page, yet Dorico is pushing the last system to another page. If I select all of the music and choose “Make Into Frame”, nothing happens. I am able to keep them all an one page by deleting all system breaks, but then I don’t have the music laid out the way I’d like.

If I try to adjust the staff size by selecting a bar and right-clicking on “Staff Size”, then if I select the preset options (60% or 75%) it will work as expected, but choosing a Custom Staff size won’t do anything. I’ve found that sometimes, by randomly clicking in a different bar, it will let me choose a custom staff size, but I cannot consistently get Dorico to do this and have no idea why it would behave this way.

How can I fix this? Thank you!

Have you tried the different setting under Layout Options? Adjusting staff size using properties is for local changes, but if you want to make global changes you should go through the settings. Sounds like you could adjust both staff size and the staff spacing to make the music fit.

If you’re making a lead sheet, then you don’t really want to use the Custom Staff Size feature anyway: you can simply change the staff size on the Page Setup page of Layout Options. But for future reference, you should find that provided you select a note (not a rest, but a note) or another staff-attached item (so not e.g. a chord symbol, which is system-attached) you should be able to change the staff size via the Custom Staff Size dialog.

Thanks. What about “Make Into Frame”? Why isn’t that working as expected?

Does it work as expected if you select the first note you want on the system and Ctrl/Cmd-click the last barline or note you want on the system, rather than shift selecting the lot? That’s the method I’ve always used…

No, it doesn’t.

In that case, are there already system or frame breaks within the passage you’re selecting? If so, click through them and see which (if any) have the “wait for next” properties set.

The “Make Into Frame” button sets a Frame Break at the start of the selection, and a Frame Break just after the end of the selection, and enables the “Wait for next frame break” property for the first frame break (meaning that none of the music between the two frame breaks can drift onto another frame. It may be easier to set these options manually if you already have breaks within the selection.

I second pianoleo in every explanation he gave you. I would not have explained it better and it surely works.

Thanks Marc!

Actually, re-reading the original post, if you’ve got a chart that should fit entirely on one page, I suspect the best way is to put a Frame Break above bar one and set it to wait for the next frame break. That will force all of the music onto one page, until you insert another frame break - which you probably won’t, in this case.

It occurs to me that selecting all and then clicking Make Into Frame may not work because there’s no music for Dorico to attach the second frame break to (remember: Make Into Frame inserts TWO frame breaks)

I admit I never had to use make into frame for one page… That makes sense, indeed.
By the way, I did not find any explanation about make into frame in the documentation, I thought it could be on page 130 but nothing… I guess this is one of the next things they will add — or something that I missed completely (and so did my pdf search engine)

Daniel says: “This Operation Manual is not yet complete: Play mode is not yet documented, some parts of Engrave mode are not yet documented…” in the pinned thread on documentation here.

That’s a diffucult one to explain:
hmmmm…I made some handish adjustments of my stave positions on my leadsheet when writing the score.
Let’s say I en-larged the spacing between 2 systems from 8 to 10 ‘spaces’.
When I’ve finished my arrangement, I remove empty staves etc…and I re-arrange my default position between systems in the ‘Layout Options’ from default value 8 to 4.
The problem is that the systems which I changed ‘handish’ before from 8 to 10 (plus 2) add a 2 to the default change from 8 to 4 — so I get a 6, although I want a 4.
I wanted to set my stave spacing to default values in engrave mode again, but no red squares (
Bildschirmfoto 2019-06-23 um 16.37.19.png
) are shown anymore:

So I can’t set the system where it had been by default. Which means that changing default settings in Layout settings don’t effect systems which I changed in advance manually the way I would like them to change and I can’t see the default position of the single staves anymore nore change to the default position.
In first place, I was stupid to make individual changes of the systems before changing default values in the page layout settings window and I won’t do it ever again.
But hey, it happened and now it’s really a mess and a lot of work to make a fine layout.
Does anybody understand what my problem is? Sorry for the complicated explanation.

I think what you’re saying is:

  1. You made some manual staff spacing changes.
  2. You’ve since adjusted the Layout Options.
  3. Now you want to remove the manual staff spacing changes, so that the newly-adjusted Layout Options can do their job.

If so, you can either select individual red squares and hit Delete, or you can marquee select lots of red squares (and blue ones too; it doesn’t matter) and hit Delete. You’ll also find useful options on the Engrave menu, here:

Leo…one more time you made my day :smiley:
Thanx man ! You got it completely right and you gave the perfect solution !

One thing I have to mention: if you have red squares and you make several changes in the page layout settings window, all red squares disappear so you don’t know anymore, where you made changes. That’s just a little notice from my side.
But your explanations Leo, solved my problem completely.

If you change the page layout, your previous formatting tweaks will be deleted, because in general they don’t make sense any more. (For example if you drag a system down, and then make the page height smaller or the staff size bigger…) That’s why the red squares disappear.

Yes and no, Rob. If you make changes to Layout Options that don’t cause your music to be repaginated, previous manual staff spacing changes remain intact.