Problem with tight spacing between lines

I am trying to get all ten systems in the attached file to fit on the first page - and yes, I know it is extremely tight.
This flow is only one out of 25 flows which form a chapter in a large book.

I have tried to use “Make into frames” and it actually moves the last line into page 1 - But at the same time, Dorico starts dividing into 3+1 bars at the first lines. That I have tried to fix using “Make into system”. It works until I reach the last line, and Dorico gives me two pages again.

I have tried Staff spacing - but reducing the space between systems on page one does not move the lost line back on page 1.

I have tried Setup | Layout Options | 10 system per page - it works, but it is a setting that seems to be global. Hence, it messes up all the 24 other flows in this chapter.

Are there something I have missed or will I have to produce this page separately and fix it by inserting it as pdf in the final book?
Untitled Project (268 KB)

When you go “make into frame” your first system break (at the beginning of the first line) becomes a Frame Break.
Go “make into frame”, then select the first break (now a frame break rather than a system break). In the Format pane at the bottom, flick the “wait for next system break” switch and it should sort it.

Thank you - it worked :slight_smile: