Problem with UAC-2 audio driver

Hello everyone, I have a problem with my audio driver.

Two years ago, I bought a ZOOM UAC-2 audio converter. I tried using Cubase with it but I got the error:

The audio driver could not be loaded. Please make sure your audio hardward is connected correctly to your computer.

I thought it was an issue with my old laptop (it had USB port issues) so I waited to get a new laptop. Fast forward two years, I got a new laptop. But I’m still getting the exact same problem. It still could not detect my UAC-2. To be honest, I really have little knowledge on how to use such a device, but all I want is to record music (doing it as a hobby) without using my phone anymore. Can anybody help me out?

I’ve tried uninstalling and installing the UAC-2 driver again and again. My old laptop could not detect the UAC-2 device, but my new laptop could. It’s kinda odd that my laptop could detect my device but Cubase could not. Is there something wrong that I am doing? Any help would be much appreciated!

I don’t have a Zoom UAC-2 interface but here are a few things to think about…

  • Do you have the latest audio driver available from Zoom installed?
  • Are you connected to a working USB port? Looks like this baby will run best on a USB3 connection. Try different ports.
  • If you have the power adapter… use it.
  • This might be the issue… Have you changed the “Class Compliant Mode” on the rear of the unit? You’d have to read the manual to figure out which setting is correct but, I suppose you have a 50/50 chance to guess because it is either on or off.
  • Make sure the Zoom is plugged into the computer, turned on, and recognized by the computer before starting Cubase.

If still having issues, please post back. Also, you really need to list your computer operating system.

Regards :sunglasses: