Problems adjusting bar width/note spacing

EDIT: Since posting this two weeks ago, I learned a far-better work-around for creating empty bars with chord symbols: create a bar repeat region, set the “Custom scale” property to 1%, and set the Count Frequency at least one bar longer than your blank-bar region (to hide the numbers).

Result: the bar repeats will be hidden, leaving the bars empty, but retaining their width.

Original post:

In the first screen shot, I’d like the width of the bars in the lower system to be about the same as in the upper.

I get that Dorico wants to make the bars with two chord symbols wider, but it’s not really necessary here, IMO.

As shown in the images, if I select the handle in red, hold the “Option” key, and tap once on the right arrow, the bar line moves WAY over the the right, the first bar on that line is now much smaller, and one bar line has disappeared.

The measures are intentionally empty. I hid the implicit rests by ending the voice at the last note prior to this section.

Am I doing something wrong, and if so, what’s the correct procedure?

Dorico Pro 3.5
macOS Big Sur 11.5.1

I don’t know if this will work for you, but I put a System Break at the end of bars 42, 46 and 50.

To test this out it would be best if you first remove any of your movements of the red handle(s). The quickest way to do this is to select a handle and press Delete.

Thanks, @stevenjones01 , but I already have system breaks in those locations.

Before posting, I had un-done movements of the bar lines, etc, so no red handles remained.

Can you share the project perhaps? I’m wondering how you’ve ended up with empty bars, because if there’s anything else in those bars that Dorico thinks it has to space, that might be contributing to the uneven horizontal spacing.

@Lillie_Harris The empty bars are intentional. I created them by hiding the implicit rests (by selecting “ends voice” for the last note preceding this section).

Sorry I didn’t make that clear. Will update my original post.

I prefer to not post the Dorico file publicly, as it’s an original composition I plan to publish/sell when the recording is released. Maybe I’ll remove or scramble the melody notation and then post it (btw, there was a helpful plugin to do this in Sibelius!).

If you want entirely empty bars (ie no bar rests in any bar), there’s a layout option for that that will probably result in more even spacing without manual intervention.

When there is literally nothing in the bar, Dorico has nothing to space and can result in very horizontally-squished bars.

1 Like

@Lillie_Harris

How does Dorico define “empty”? For example, if something is attached to a bar -a chord symbol, coda sign, repeat sign, tempo marking, dynamic marking - is it still considered empty?

I wasn’t aware of the option to de-select “Show bar rests in empty bars.” Thanks!

I tried disabling that, and nothing changed.

EDIT: Although disabling “show bar rests in empty bars” didn’t work at first, it DID work after I un-did the other (older?) method of hiding rests - I disabled “ends voice” for the preceding note.

For the particular charts I’m working on, this option is great, because the only measures containing measure rests are ones where I’d want them hidden - i.e., in the improvisation section of jazz songs.
The notated melodies contain no measure rests.

But if they did, the Layout Option would hide them when I wanted them visible. Is there another solution for this scenario?

If you remove rests using Starts/End Voice, the measure is truly “empty.” If there are text items attached to the downbeat, the measure is still empty (at least as concerns things like multi-bar rests.

But as regards horizontal note spacing (which is your question), removing the rests always causes the same unpredictable behavior, even if a dynamic or a chord symbol is attached to any point in the bar.

So the takeaway is to use the intended function here, rather than removing the rests.

Yes, I get that hiding bar rests, not removing them, is the way to go.

Any thoughts on the last question in my previous post - i.e., what if I needed to hide most, but not all, of the bar rests? Is there a way to do this?

Looking forward, one possible solution might be a “hide bar rests” (or “empty bar”) region, analogous to a slash region. Like a slash region, it could conceal music underneath which would play back but not print.

For now, select the unwanted bar rests and scale them down to 1%. To make sure they’re slap-dang gone, you can also set their transparency to 0 using the color property (Alpha channel set to 0).

1 Like