Problems launching Dorico 5 on Windows

May have no impact at all, but I have to ask: have those with difficulty opening Dorico 5 on Windows rebooted their computer after installing but before trying to open Dorico?

I tend to do this automatically. It may no longer be necessary for Dorico or may only apply to loading fonts, but its something easy enough to try if Dorico 5 is not opening smoothly.

Surely will do - and thanks as ever Ulf

Not sure to want this update.
Tired to have always problems with the audio engine in dorico.
I keep and stay on v 3.5.
My v 4 is not used and just 2 hours after the v5 , i see problems with the same part.
So sad for this good software…

How can you possibly presume you will have the same problems if you haven’t even tried it? Perhaps you can wait until the demo and try running D5. Considering it’s what… 2 years? of further development, it seems odd to presume you’ll still have problems just because one or two users have reported an issue (and this is the overwhelming minority).

1 Like

Hmm pretty strange i have seen it make a zip file but i think there is nothing much in it - 22 bytes - empty. Reinstalled D5 from website rather than SDA. Same result audio engine initialise then audio process died. Admittedly i have a lot loaded on this old i7 win 10. There is a usb 10 port hub on it - a couple of external hard drives and logitech multi device keyboard and mouse. So a lot for a new entrant program to cope with.

Still Dorico 4 still seems happy.

Will keep trying for the diagnostics zip

And you can have version 3, 4 and 5 installed peacefully side by side. And if one of them would not work (for whatever reason), you can start up the other one.

Additionally, we give our very best to get people up and running any of their installed versions.

1 Like

@nomisllewdor, please try using the SDA instead. The SDA installs also some other now necessary stuff on your computer. It’s related to our new shared MediaBayService, that is used by several Steinberg products. So please run SDA and let it do its update, and then try to run Dorico again.
But before runing SDA, make sure that no Dorico is running.

Agreed. I am having problems with D5 but I didn’t with any of the earlier releases. And frankly used to it with all kinds of software. The fabulous Dorico team will do all they can to help me through it and i have total faith in their commitment to music and quality 21st century music software. No regrets at all on buying the upgrade first thing this morning.


Yep i’ve done it both ways Ulf - SDA and website installed additionals and media bay both times. Gonna have another look at getting you that zip file after I finish with the live stream best S

Hi @rvolkman , may I also ask you to run Steinberg Download Assistant (SDA) once. It will look for available updates for itself and install them automatically. SDA then also installs some Steinberg commonly used software which is shared by several Steinberg products. Among that is the MediaBayService. If you don’t have the latest of that one, then also Dorico 5 will get into trouble.
Therefore, please kill off Dorico, run the SDA again and let it do its update and then try with Dorico again. Any better?

Hi Ulf,
Interesting D5 has installed and launched OK on my (work) laptop. Soooooo for the Desktop…

  1. Could be a problem with logitech wireless keyboard i suppose. So lets see what happens with a wired mouse and keyboard

  2. Perhaps problem with the usb hub.

  3. Norton anti virus causing trouble maybe.

Will try these and let you know if any change

Hi Ulf,

I always do use the SDA. However, I decided to reboot the PC and after reboot, Dorico 5 runs as expected. Problem solved!

Ron Volkman


Perhaps i am wrong but why i have the feeling that dorico team try to have a good product and I feel some people try to destroy their job !!!
It is like the audio engine part breaks the good progression since v3.5
So I still using v3.5 whose have a good sound and no audio problem.
It’s like we are punished by paying a product with many problems.
You can blame me but I am a simple customer and if i am right, i hope my message will go to the top direction for a best product and collaboration .
My feeling is that : the audio engine and autorisation , sda, part is a break for dorico .

I am sorry you are having difficulty.

I have to say that I have used SDA since version 1.0, and although the switch from the old authorization to the SAM was somewhat confusing, I have never had difficulty getting Dorico upgrades and updates up and running (so long as I restarted my Windows machine after doing the upgrade).

  1. I found the process pretty standard:
  2. Buy the upgrade
  3. Download the upgrade file (new version of the SDA)
  4. Copy/Paste the Authorization Code into the SDA
  5. Navigate to the Dorico 5 Upgrade icon
  6. Click Install All (make sure neither Dorico 4 or SAM was open)
  7. Restart my computer
  8. Open Dorico (which took a long time to open the first time, as I expect it was transferring Dorico 4 preferences to the new Dorico 5 Folder)

Tried a few things but the problem is still there. The audio initialisation message appears but it goes quickly to audio process died. Earlier in the day it took longer for that message to appear. I read somewhere your response to someone else a while back that the audio engine never got started. That rings a bell because when i check the processes in task manager i don’t see it hanging there - although i do see Dorico 5 still loaded. Still can’t seem to get a meaningful diagnostic zip file for you either

Default Asio sound driver is Focusrite usb for Scarlett. I have also checked this loads OK in Nuendo 12. Starting to think about closing start-up programs and processes to see if this has any effect.

Hi @nomisllewdor , could you please check the version of the files
C:\Program Files\Steinberg\MediaBay\SteinbergMediaBayServer.exe
C:\Program Files\Steinberg\MediaBay\medialib.dll ?

Find those two files in File Explorer, do a right click on them and choose Properties, then go to the Details tab. Is it version 1.0.20?

Additionally, did you do a reboot of your machine in the meantime? If not, try that and see how it goes afterwards. For user rvolkman it did the trick.

Medialib.dll 1.0.20 1047 dated 18/03/23
SteinbergMediaBayServer.exe 1.0.20 1047 dated 18/03/23

Yup trying full reboots from time to time :grin::+1:

Yup another full reboot still the same situation. I deinstalled D5 and reinstalled it from SDA as well and added all other stuff u=in the D5 folder in SDA

Okay, thanks, the version numbers are as expected.

Could you please get the free utility Process Explorer from here?
It:s similar to Task Manager, only more reliable.
Then when Dorico is hanging, have a look in Process Explorer if you can find also a VSTAudioEngine process. If so, do a right click on it and choose Create > Create Mini Dump. The corresponding dump file please zip up and post here.
Also, I could not reach my other colleague, yet, but I hope for tomorrow.

I’m getting the same error every time, rebooting and reinstalling doesn’t help: Audio engine process died. (1.9 MB)