Problems on mac with some plugin brands

I’ll start this topic by saying that Wavelab is an amazing piece of software and I’m using it from many years ago, probably since version 2 or 3 if I remember well.
The problems started before some years when I moved to mac osx.
Generally speaking, I have no issues with the most plugin brands such as uad, plugin-alliance, softube etc. They work great inside wavelab. But there are some brands that are almost unusable. I’ve noticed that from Wavelab 7. In fact, in every update until now ( v8, v8.5, v9) I was hoping that these issues will go away and that was the main reason for my choices to update and secondary the new waveleb added goodies.
And to be more specific. Some plugins such as Slate Digital, Tritone digital, Tokyo Dawn records bundles, to name a few, there are serious gui issues that make them totally unusable and in the most cases they also freeze wavelab.
I’m sure PG knows that, I’ve read that many other mac users have also the same problem.
My question is: Why so much silence from wavelab’s support? Why someone does not suggest us a workaround?
I’m not saying that wavelab is responsible for these issues, it could be something that the affected plugin brands may have to change, even if in other daws they work perfectly. I don’t know… I’m not a software genius but I expect from wavelab developer a solution. Maybe I have to ask support from the plugins manufactures? Even if there is no solution, I would like to have an official statement that this is never going to be solved. At least I have to know if I will hope for a solution or no.

Kind regards,


Hi Nikolaos,

Thanks for the report, and I know where you are coming from. There is something interesting about how WaveLab handles VST3 plugins compared to other DAWs. I also use REAPER and Pro Tools (long time user) and for as short time used Logic in a basic way and I had never seen these kinds of troubles with those DAWs using AAX and AU formats. As I started using WaveLab more, it was incredible how many plugin issues I saw. Whether it was a minor GUI bug, serious crashing, or situations where plugins were audible on playback but were not included in the rendering.

To say who is right and who is wrong is subjective I suppose, but I do wish that WaveLab could be more friendly to 3rd party plugins. Either providing better tools and resources for coding, or relaxing some extremely strict and deep specs to avoid these recurring issues. When I started using REAPER which uses VST and AU, I decided to stick with AU instead of VST3 just based on my WaveLab experiences with VST.

In general, I try to stick with the bigger companies like UAD (which doesn’t technically support WaveLab but works surprisingly well), Plugin Alliance, iZotope, FabFilter, Waves etc. because those seem to have less issues. The smaller companies seem to be more problematic, probably due to resources. For me, if it’s a smaller company the plugin has to be VERY good to even bother to try in WaveLab because most of the time, there will be an issue of some kind to deal with. To my surprise, I recently started using Limiter No 6 to replace NUGEN ISL2 as my “Intersample Peak Limiter” after my main limiter. It’s from a small company, and free (usually a sign of troubles), and to my surprise works perfectly so far. However, they have only made a VST2 version and from what I hear from developers, VST3 is very challenging to code for vs other formats so it’s no surprise they are VST2 only. Sonnox and UAD ares still VST2 only as well.

Nearly all NUGEN plugins have some SERIOUS issues in WaveLab where even opening the GUI or manually typing in a value will crash WaveLab. I have provided NUGEN and PG plenty of info and crash reports but still, no solution so I gave up on using NUGEN in WaveLab.

I recently tried another unique plugin from a very small developer and again, there is only VST2 because VST3 is “such a mess” to them. When I reported a GUI issue with even the VST2 version in WaveLab, I received a reply saying they simply stopped testing plugins in WaveLab because of all the headaches. This is not the only time something like this has been said from other developers as well.

This ties into my theory that many of these companies (large or small) are not even testing their plugins in WaveLab. I think they mostly use Cubase as a testing point and assume or hope that they will work OK in WaveLab as well. It’s probably a combination of WaveLab having a smaller user base than Cubase, combined with the quirks of WaveLab, and challenges of VST3 in general.

This is clearly a problem.

I’ve spent so much time providing info to PG as well as the plugin developers regarding plugin issues. I’d say most of the time, the fix needs to happen on the plugin side but not always.

I’m now on the beta team for over 5 major plugin developers…not because I want to be but because I end up reporting WaveLab issues and nobody else seems interested or willing to help test and figure it out so they send me beta versions to try. This is great on one hand for me personally, but on the other hand…could be a paid gig for somebody instead of passing it on to users/customers.

I would urge somebody at Steinberg to take a look at VST3 and how they can make it easier for developers to make plugins that work correctly in any DAW that uses VST3, instead of the mess we have today.

WaveLab 9 is clearly better than 7 and 8 in this regard, but still more problematic than any other DAW I’ve ever used.

I have worked on this recently, solving a case in a NI plugin, for WaveLab 9.0.30. Some more tests need to be done. It would be too technical here, but some plugins are not written in the best way and WaveLab puts them at stress because of its multi core oriented nature. I am not speaking about the DSP quality of the plugins, but about what exists around it.

Does this have the potently to improve plugin handling in general within WaveLab or is this fix only specific to NI plugins?

I also unterstand it may be too early to know the answer to that yet but just curious.

The problems did not only occur on mac but on PC too.
I recently became problems with a plugin from East West Queantum Leap (Spaces) A very pristine reverb.
Till WL version 8 it works good, but since version 9 several problems occured. When I contact the developers they say that the problem maybe is not on their side while they follow the VST 3 specs from Steinberg. In Cubase this problem did not occur. (is full compatible)
They investigate the problem but I thought that it was a problem on the side of Wavelab.
I hope that this kind of compatibility problems could be solved by PG.
It is sometimes very frustrating.


Hi Nikalaos, Justin,
I hear you with regard to the fact that a number of plug-ins give problems in Wavelab but not in other software. It could be smoother.

Of course it would be great if things could be made easier for programmers. Perhaps part of the problem is that VST3 became way too difficult to program.

Just for the record, all my plug-in collection works fine in WL9, and this includes SSL (VST2.4), PSP (VST2.4), Sonnox (VST2.4), Voxengo (VST2.4 and 3.6), Melda (VST 3.6) and NI Reaktor FX (VST2.4). Things have improved over time. I used to have problems with SSL X-EQ but that got fixed on SSL’s side.

(I probably got lucky and I’m not a super heavyweight plug-in user).

Perhaps a part of my issue is that tend to prefer the VST3 version when they exist over VST2. I much prefer the preset menu of VST2 vs. VST3.

While this is partly my choice, VST3 has been around long enough that developers should have been able to develop stable VST3 versions by now.

The fact that some developers don’t even offer VST3 yet, and many of the VST3 versions that do exist are largely prone to minor and major bugs is telling.

Also, the fact that Steinberg recently stopped offering the VST2 SDK, or at least announced that the end is nearing for VST2 support is also telling.

I’ve learned which plugins to avoid and how/where/why/when but it’s something I’ve never had to do with any other DAW and unfortunately WaveLab is the exception.

I actually am a fairly light plugin user in WaveLab because in most cases, I have the songs dialed in pretty close already using REAPER and my analog chain. I mainly use WaveLab for the montage assembly of an album, adding a final limiter and dither on the montage output effects, a few clip plugins as needed. The strengths of WaveLab are the mastering focused workflows and rendering the final master files, and I’ve learned to use plugins less and less to avoid problems which for me are largely retailed to rendering crashes, or crashes in general.

Yes, the VST2 / VST3 situation is delicate and seems to have given birth to a lot of issues. Interesting to hear how you use WL.

I tend towards a lot of editing and processing in the Audio editor with quite sophisticated plug-in processing chains in the Master Section. Works well and renders fine most of the time. I’ve recently discovered I can use Reaktor in there which didn’t used to work IIRC. Happy about this because I have quite a lot of custom processing tools in there.

Thanks everyone here, one by one, for taking the time to reply.
As a first step forward, in a few days I’m going to check all my plugins and report exactly the brands that give the issues (here I want to notice that all these plugins that I’m talking, work incorectly on both vst, vst3, otherwise there would be a workaround to use the one format instead of the other).
After that I will try to find the time to ask support from all these manufactures one by one.
At any case I don’t want to move from Wavelab, after so many years it is my “editing” & “mastering” home and the most of my 3nd party plugins work perfectly, but you know my friends: In this audio world even if you have dozens of useful tools, there will be always some of them that can give a part of your signature in the final print. And here happens 1-2 of them to belong in the problematic list.

IMO a good idea.

In all honesty, most of the problems are likely to be caused on the plug-in side. The real fun and games would begin if ever steinberg decide to completely drop support of VST 2. Most of us would hope they never do, given that some developers show no signs of moving their plug-ins to VST3.

As an example of a developer that keeps right up to date with VST, the Melda range of plug-ins is upgraded on a continuous basis (this has led to some great results). I noticed that currently their plug-ins use VST3.6.5 which is a later VST version than the plug-ins supplied with the program!

It would be terrible if Wavelab dropped VST2. How would we open old projects? There’s no VST2 to VST3 settings translation in Wavelab that I know of. Not to mention UAD is VST2 only.

I’m considering switching everything over to VST2 in new projects because of playback dropout differences between VST2 and VST3 at very high sample rates (192k) when using long chains that include heavy processing third party clip FX, like AirEQ and Ozone, so I’m especially interested in this.

The situation is much better in WL9 than it was in 8.5.30, but I can still get dropouts using all VST3 plugs if making adjustments while playing, using a mix of FabFilter, Waves, UAD, Eiosis, and Izotope. It’s a pretty extreme chain, but it’s repeatably more reliable with the VST2 versions. And it’s not just a Wavelab thing.

But don’t ever use FabFilter Pro Q2 VST2 on a clip in Wavelab. That’s still broke, and will always crash.

Steinberg is not going to drop support for VST2 within its current major applications, at least for the time being.

Yes. I was trying to trouble shoot this deep memory related crash I have while rendering so I loaded up the VST2 of FabFilter Pro-Q and was reminded quickly about the playback crash.

I remember FabFIlter saying it had to do with lack of side chain support in either WaveLab or the plugin (can’t remember) but it seems that neither party is interested in fixing it.

FabFilter said it needed to be fixed by Steinberg. That any VST2.4 plugin with sidechain would crash when used as clip plugin in Wavelab because the extra sidechain connections could not be made (or something to that effect) and that was the fault of Wavelab.

Maybe some code has been updated, because for me the only plug that I couldn’t get to load correctly was SurferEQ. Slate worked, Tokyo Labs worked, NuGen worked, etc. I’m using a late-2012 iMac running El Capitan. I’m running the most recent trial of WE 9, 9.0.35.

I am a little upset that Pro Q2 VST2 won’t work, as I had hoped to buy that sometime in the future.

The Pro Q2 VST2 crashes when used in the montage only (clip, track, montage master slots). It works ok in the wavelab master section. Wavelab was never fixed to make the extra VST2.4 connections in the montage according to FabFilter.

The “fix” is to use the Pro Q2 VST3 version instead. That works in all wavelab slots.

The other continuing plugins problems are mostly mouse-up related problems on Mac only I believe, which might not be immediately obvious. Those are still pending afaik, and any other problems have mostly been reported, but it certainly would help if you reported anything you find to the plugin maker, and here.

Except for the SurferEQ which is still pending.