Problems recording with ASIO driver and Presonus StudioLive mixer

I want to record stuff in this program so I can check out the SpectraLayer scene real quick. I’m doing sound design with synthesizers and stuff.

When I open Preferences, it tells me this WASAPI Type is selected. This thing sucks because a) it doesn’t work, b) it only sees 2 channels, but my audio interface is my mixer, which has 16 channels.

When I select ASIO, and select ASIO Presonus FireStudio as Input, it looks better because I can see the 16 channels, but an errors pops up and says

The problem actually wasn’t the drivers. “Exclusive Mode” was enabled in the sound card properties, which caused the issues. To fix this, I went to playback devices, right click on the StudioLive>properties>advanced> and uncheck “Allow applications to take exclusive control of this device.” Now I can have a DAW open and play audio in other applications at the same time. :smiley: