Problems with Cubase

( In very beginning, I apologize my english, hope you still understand the point)

Hi, I dont know, if i am a kind of stupid or what, but…
Friend of mine owns Cubase, and he is using it a lot, so i took this 30 days trial, so we can use same program while we’re recording songs together, we have quite distance between us, so this seemed to be very good tool to us.
And i have to say, I am not an idiot with computers, but neither profs, ok thats the intro…

First, the installing was hell, first some dll:s etc errors, and that was the easy part, then was problems with elicenser, it was too old…(it was newest), it was not complete…, it was not connecting… what a mess. Finally today i succeed to complete the download, and it worked, but there was n sound. I checked in studio/studio setup -> dropbox and there was only “no driver”. There wasnt Asio, or the genereic low latency Asio, or anything. So i restaretd my pc, and after restarting, my elicenser was gone, so i download it again, and guess what i couldnt anymore open my Cubase, i tried to put the activation code, and it said, code is already used, so thats it. After weeks of strudggeling, it worked for 1 hour, and then its gone. After this nicw experience, I think, that I pass this product, its clearly not for “average” people.
Maybe if i’d buy this product, it would work more fine, or smth, but after this bad start, i think i will put my money in some other program.

Does anybody else share this with me? And if, did you worked it out?
Or maybe i am kind of stupid after all…

Hi and welcome,

Hae you used Cubase Elements Trial or Cubase Pro Trial?

Have you installed as adminsitrator?

Once you start eLCC application, can you see your Soft-eLicenser or USB-eLicenser? Have you registered your USB/Soft-eLicenser? What happnes when you trigger Maintenance?