Problems with Dorico UI, when at 150% global OS scaling

Hi,

Since I am planning to buy my first notation software soon, I am testing the current Dorico trial version.
I am still on Windows 7/64bit, which I understand is not officially supported anymore. But since there are reports from many users that Dorico is working flawlessly under Windows 7, I wanted to give it a shot.

Now here is my problem: I am on a Laptop and my global UI scaling in the Windows settings is set to 150%. Unfortunately, when starting Dorico the UI is basically broken (buttons not showing full text, UI elements too large, therefore some elements not visible).
Now I initially had a similar issue with Cubase 9, but this could easily be fixed by right clicking Cubase9.exe and selecting “Disable Display Scaling On High DPI Settings” which fixed all problems within Cubase.
However, the same workaround has no effect on Dorico. I will admit that the UI looks fine when setting the Windows OS scaling level to standard 100%, but keeping the OS scaling at this level is unfortunately not an acceptable long term solution for me.

So my questions would be:

a) Is there anything I could do to resolve this problem?
b) If not, does anybody know if the Dorico issue with the global scaling exists on Windows 10 as well?

Thanks a lot!

You might find this thread interesting. I think the long and the short of it is that Dorico looks good at 100% and 125% scaling, but things become disproportioned when you scale to 150% or more.

Thank you for the link. After reading, I still have two additional questions:

  1. Why does Dorico ignore the “Disable Display Scaling On High DPI Settings” checkbox set in the Dorico.exe file? Can that be fixed?
    In my case, the 100% scaling setting would actually be fine for using Dorico, it is just very annyoing to switch the OS scaling back and forth every time I want to work with Dorico.
    Alternatively, is there an easy way to include an “Ignore Windows scaling” in Dorico’s options or would this be too complicated/taking too much time?

  2. I would be interested to know what your plans are for making Dorico hi-DPI compatible in the medium and long term?
    Given that hi-DPI displays are becoming more and more popular and screen resolutions increase every year, the current status of “Dorico only works between 100% and 125% scaling” sounds a little worrying.

I’m using Dorico on Win10 on a Microsoft Surface book (3000 x 2000 hdpi display). Dorico appears to be obeying OS scaling correctly (I tried 100,125,150, and the recommended 200%). I didn’t see anything particularly wrong at 150% on my display. With Sibelius I run it with hdpi scaling overridden with system driven scaling. Both seem to work fine on hdpi displays, although I think Dorico’s UI looks a bit more modern and cleaner on my Win10 machines.

Thanks for confirming, Traubitz. We have a Surface Pro 3 here in the office and because the display is quite small, it’s not really practical to go much beyond 125% scaling, but I’m pleased to hear it’s working as expected.

Hi Traubitz,

Thank you for checking. Unfortunately, I can not confirm your findings. I installed Dorico on a second computer that runs Windows 10 and the problems were exactly the same. A possible reason might be, that I run a FullHD resolution of 1920x1080 and not 3000x2000 like you do.

I attached 2 screenshots: Initially it seems only the writing on the buttons is broken, but as soon as you click one of the major tabs, to switch between write mode and engrave mode for example, the screen is cut off on the right (see attachments).


The problem, I’m afraid, is that the width of the display is not sufficient for all of those buttons to fit in at 150% scaling. You can access all of the functions provided on the toolbar by other means, so you could consider hiding it (Ctrl+6) and using the menus or key commands to switch between the different modes.

On the subject of how scaling looks:

At 100% scaling, is the menu text bigger in Dorico than in other applications on purpose? The native size is more natural to me.

For fun, I took a 1920 x 1200 native display and set it to 150%. It seemed OK, but crowded. (This is more or less the current Dorico 1.1)


This one was driven by a Nvidia P4000, the other was an Intel HD 520.

For windows 10 setups, I always recommend running the display at its native resolution for the panel (e.g. the number of pixels that are really there) and then use OS or application scaling as required. This usually avoids application issues.

Daniel’s diagnosis seems the most likely, that is, Dorico is getting crowded by the combination of resolution and scaling. (Perhaps too much scaling in this case.)

HTH,
-T

On the subject of the size of the menu text in Windows, this will be fixed in the next update.

@Traubitz:

Thanks for testing that - now I am a bit confused. :confused:
The second computer I tested Dorico on is a Windows 10 desktop with a Geforce 970 graphics card. With that PC, I use an older 27’’ screen, which features exactly the native resolution you posted (1920x1200). Obviously, with that screen size I wouldn’t need Windows scaling, but when I set it to 150% in the Windows 10 display settings for testing purposes, it creates exactly the same problems in Dorico I posted above instead of looking like your screenshot.
It’s not just a problem of width, I also can’t see the bottom of the UI as soon as I choose a work mode. Basically, it looks like only the top left portion is visible and the right/bottom are omitted.
My Windows 7 laptop has an Intel onboard card as well as dedicated Geforce graphics card - but using either didn’t make any difference.

EDIT:

I discovered something interesting: If you switch Dorico’s language from German to English, the scaling issues become much less problematic - presumably because the English words for the modes are shorter, thus needing less space?
When activating write mode for the first time after opening a project, my screen on the Windows 10 PC @150% scaling looks exactly like your screenshot. :slight_smile: Unfortunately, when switching from “write mode” to “engrave mode” and back to “write mode”, the tool bar on the right of the screen disappears… :neutral_face:

I was able to confirm on my version with English language setting. On a 1920 by 1200 display with 150% Windows 10 OS scaling, if you load up the Dorico with window at maximum, and switch back and forth between Write and Engrave mode, when you return to write mode, the right hand part of the interface is cut off.

Requirements to Reproduce:

1920 x 1200 display
Windows 10
Dorico in English

Steps to reproduce:

  1. Set Monitor to 1920 x 1200 native resolution with 150% scaling in the Windows 10 Display Settings
  2. Start Dorico
  3. Load Coldplay – Clocks demo score
  4. Select Engrave and then select write again

Result should be the right hand panels are cut off.

This issue is caused by the fact that the panels cannot show scroll bars, which means that when they are shown, the window ends up larger than the display. The forthcoming update has some changes in this area: if the panels are hidden, the minimum height of the window will be smaller. However, as soon as you show the panels, the window will snap to the minimum size required by the panels.

I will try to make some additional information regarding the required minimum screen resolution at different scale factors available on the resources page on the web site, where the system requirements are given.

@Traubitz:
Thank you again for confirming the display issues. It is very helpful to know that the problem isn’t just a mistake on my part.

@Daniel:
Just to make sure I understand correctly: Basically Dorico does not support 1920x1080@150% scaling for the foreseeable future and will therefore always show display issues at these settings?
Because as much as I like Dorico’s approach, I’m sorry to say that I can’t really purchase a notation software that is not displayed correctly on the laptop I use.

Good to hear that.

I find both scaling options on the Surface Pro (2160*1440 px) difficult to work with.

This is Dorico at 150% (default setting) with giant symbols/icons/buttons and large menu text (also, the Hub takes up nearly the entire screen):

And this is Dorico at 125%, the next smaller setting. Now with minuscule buttons and menu text, quite difficult to read and not really touch-friendly:

Something in-between would be nice. All my other apps, including Steinberg Wavelab Pro 9, get the scaling perfectly right at the default (recommended by Windows) 150 % setting, and they remain usable at 125 % (albeit a bit smaller), but Dorico is much “bigger” at 150 and much smaller at 125.

One interesting observation is that during startup, the splash screen changes radically in size. When starting at 125 %, the splash screen starts out small and then gets enlarged a lot; when starting at 150 %, the splash screen starts out extremely big and then scales down to a quarter of the original size. Something strange is going on here.

Something in-between would be nice. All my other apps, including Steinberg Wavelab Pro 9,
get the scaling perfectly right at the default (recommended by Windows) 150 % setting,
and they remain usable at 125 % (albeit a bit smaller),
but Dorico is much “bigger” at 150 and much smaller at 125.

As I pointed out here: https://www.steinberg.net/forums/viewtopic.php?f=246&t=117661 (about halfway down the page – on Fri May 19, 2017 8:42 am and Sat Jul 15, 2017 8:42 pm), setting 150% on my computer (the recommended setting that I use all the time), while it works properly with other programs, actually sets the scaling of Dorico to 200%, which is far too large. Perhaps this is what is happening with your computer also.

I would like to see a resolution of this problem that allows me to see more of the score and less of the menus and palettes at the edges of the screen. For anything more advanced than a small change to a note, etc, Dorico is extremely clumsy on my laptop and navigation not easy.

David