Problems with Driver-Installation (UR22)

Hi all,

I’m slowly becoming desperate!

I bought the UR22 and would love to finally start recording on my laptop.
Unfortunately, the installation of the driver ends with an error (tried 1.8.3 & 1.7.3):
“The installation of the driver failed”

Only remaining option is to click the OK-button…I tried it on another laptop and it worked just fine! No problems at all! But…it’s not my laptop! So, I really have to get the thing working on my device.
Tried it also in the device manager; but it’s not finding any drivers.

Anybody know how I could fix the problem? Would really appreciate any hint!
Thanks in advance!

What a service!

Hi Sasan,

To give advice it would be really helpful to have some more information on your system, since a laptop is a very wide range of possible combinations of system components.

If you like please get in direct contact with our support team that might be faster than waiting for response in the user forum. However, please give us some details on you system.

Best regards,
Stefan Schreiber

Hi Stefan,

please find information about my laptop below:
HP Envy
Intel i7-4700MQ 2,4GHz
Win 8 (64 Bit)
Anything else?

I think I’ve deleted all unused items from the USB equipment list (deleted with GhostBuster)…other methods to do so? As soon as I plug in the UR22, it appears in the device-manager of windows under “other devices” with a yellow !-triangle.

I contacted the support before my first post in this thread, but haven’t gotten any answer yet…

Thanks & regards

Hello Sasan,

Make sure you are logged-in in an account with administrative rights.
Have you tried also creating a new account in your computer with administrative rights and try to install the drivers there.
Make sure you are installing the 64 bit version of the drivers:

Best regards,

Hi Guillermo,

I tried to install it logged in as the current user with administrative rights as well as the administration user. I get the same error message. Definitely used the 64 bit version from your link.



Could you please create a new account on your computer just for test purposes.
The problem you have might be on your current user account.

Best regards,

Same problem…

Hello sasan,

Unfortunately I have ran out of ideas please get in contact with the support through you MySteinberg account and arrange a remote support session.

Best regards,

Hi Guillermo,

just restored the laptop to the delivery status. Everyhing works now.
Don’t know what caused all the problems, but my guess would be a faulty registry-entry or other disturbing drivers!

Thanks anyways!