Problems with FLAC (stutter/skipping/silence)

Hello all,

Recently, I recorded a new project from scratch. That means drums, bass, guitars, vocals, synths, etc etc. Since I use Cubase 6.5, my settings were, ofcourse, changed to FLAC files in the background and everything worked fine!

Until the moment I had to use VariAudio on some vocal parts. All of a sudden I had dropouts. Entire parts were not being played and I couldn’t figure out, why not?

So I searched on the forums and I found the question about Freezing tracks and some people said it was because of FLAC. So I checked my problems a bit more focused this time and found that the Drive Cache was overloaded, everytime I used VariAudio or something else (HD?) intensive. When I changed it all to WAV, problems went away and mixing was becoming fun again!

So now my question: I’m recording/mixing on a QuadCore 2,4 gHz Intel Processor, 4GB ram and 2x 1TB Seagate 7200 RPM disks. What is the problem with FLAC? Is it the HD’s? Is it the CPU? Combination of?

I hope somebody can shed some light on this issue. I wrote down the issue exceptionally detailed, so other people with the same problem can find my topic AND the answers, hopefully!

FLAC is a compressed data format, which means for streaming functions (like recording and playback) the CPU has to encode/ decode the audio data in real time. Always best to use an uncompressed data format like WAV or AIFF, because they represent what goes through the CPU without recalculating anything.

BTW, I don’t see what you mean by this: “Since I use Cubase 6.5, my settings were, ofcourse, changed to FLAC files in the background”. That shouldn’t happen AFAIK.

Thank you for your answer. Do you mean Cubase doesn’t do that automatically? If that’s the case, then I probably changed it myself, but can’t remember! Haha.

But I guess my CPU is the bottleneck then, if what you say is correct.

No, it shouldn’t use FLAC automatically. And, you could say, your choice for FLAC is the bottle neck - there’s no reason to use it natively. It’s a good format for online collaboration exchanging of files, so it’s good we have it…

So, you’re saying there isn’t a computer that can handle FLAC files in the background? If that’s true, you are right. If that’s not true, it cannot be my CHOICE that is the bottleneck, but one of my computer parts :slight_smile:

I’m not trying to sound like a wiseguy, but I’m actually interested in which part should be upgraded, if I DO want to work with FLAC files in the background :slight_smile:

In that case, your decision making should be upgraded :sunglasses:
Most likely it’s the CPU that’s most burdened by the realtime coding/ decoding.

Hi guys,

Arjan P is correct in his opinion. On a modern system the real time de- compression will not being recognized.
The Multi- Core CPU will handle this without bothering your work at all.

Lower spec systems will suffer a bit during the real time de- compression, especially when you have recorded a lot of tracks/files in your project in FLAC.

So a work- a- round will be very easy:

  • Open the Project Setup and change the recording format to WAV or AIF

  • Open the Pool Windows and choose all Audio Files and right mouse click and choose “conform files”

  • You can export your Audio- Mixdown as FLAC- file



This is exactly what I did.

But just to be clear: I do have a ‘modern’ Multicore CPU system.I’m using a Quadcore 2,4 gHz intel CPU with 4GB of RAM and standard 7200 RPM disks. It’s my disks that seem be having the error.