Problems with Groove agent 4

Hi all
Hope someone can help me out.
I have bought Absolute 2, with which came Groove agent 4.
I have for some time had Grove agent one /se 4, which work perfect. I also have Ezdrummer that also Works fine.
The problem is that GA4 dont work for me. When i bring up the application interface and press different pads i hear the drums loud and clear but when i play a midi piece with drums it dont sound at all. I have of course set CB8.5 to groove agent main with channel 10 (have also try setting it to all other), but it dont help. When i change cb8.5 to fx ezdrummer or GA one/Se4 everything Works fine. What am i doing wrong?
Best regards

Anybody ?

Check how ezdrummer mapped notes to the drummap and then check what GA4 does, I think that quit a few are mapped differently and if playing the same midi piece you need to remap notes.

Sorry, i have tried every notes in the drum editor, non of them makes sound.

Are you triggering Goove Agent’s pads with your mouse or your keyboard? I use my keyboard and and pads to play drum parts and I’ve also liked working with some of GA’s patterns. The Pattern Pads have a lot of options and it’s a complex unit. Good luck getting it up and running.

I use Channel 1 for my main pads and Channel 2 for the pattern pads. All works fine. Keep hacking at it.

It should work just fine and does for me. I use GA-SE 4.2 but plan to upgrade to the full version soon. So far, GA has been one of the more useful of the synths that came with CB Pro 8.

Hi there

Possibly to do with the “Drum Map” box in the inspector section? Had a bit of a problem with that once.

Best Regards


Hi all
I dont think its the drummap. I tried all the notes in the drummap.

What about midi channel in drum map?
Is it set to channel 1?

Thank you for all your answer.

I load up my Groove agent 4 fx Blues heritage. A very nice sounding set. Midi channel set to 1 ot 10 or any. Makes no diffenrens . In the inspector i choose Groove agent - Main. Drum map set to GM map.

Whenim in the drum set i can with the mouse play all the pads and they sound fine.
But when i set some notes in the drum editor no sound except for some notes which gives fx both snare and kick at the same time. When i poit one note with the mouse in the drum editor, it will playa series of drum notes.
But the notes for fx the acustic snare which is set to D1 dont sound. And i have tried all the notes in the drum editor.
What am i doing wrong.
If i use the old dumset Grove agent SE its all normal and sound correct.

Best regards fra lmlmlm

Don’t use GM drum map.
Use the create drum map from instrument function.

GM drum map is using channel 10 by default.
This setting is independent from the midi channel in inspector.

What’s probably happening is: GA is expecting notes on channel 1 (default setting for GA unless you changed it), but once you select GM drum map, the notes are sent on channel 10.

You can change the GM drum map midi channel but Create drum map from instrument would be better option.

I Will Try that.
Best regards from lmlmlm

Hey misohoza

thank you very much for your reply. That did the trick.

best regards lmlmlm01