Problems With Macro Editor ( crash ) and Running Macro

In an effort to solve another Nuendo editing shortfall I built a Macro.

The idea is to locate to a Marker ( with auto select on ) on a track of many separate events , then cut and copy the the audio event at the marker to an existing blank track below in the Project window . Then move to the next Marker and repeat.

1: when building the Macro after about a dozen or so edits the Macro editor stops visibly adding/removing commands. Shortly after Nuendo 11.0.1 hard crashes ( crash log attached ). Relaunching Nuendo displays the previously invisible edits and works for another few edits. Then does the same thing.Nuendo 11_2021-02-24-141703_Lees-iMac-Home.crash (141.2 KB) Nuendo 11_2021-02-24-141703_Lees-iMac-Home.crash (141.2 KB)

2: When I finally got the macro working it went like this for one event - and works
with Track 1 ( audio source ) selected and the Preference Auto-select events at Cursor on
Step 1-
-return to start

  • locate next marker
    ( this moves cursor to the first marker and selects the event on the track beneath )

Step 2 ( actually contained within another separate nested Macro )
— Cut the event
— Navigate down to next track
— Paste event on new track
— Navigate up to source track
— Locate to next marker

As I said this works . My Cursor is now at the second marker ready to cut/copy again. In fact if I just run the nested macro again ( separately from the macro list ) it does what I want. The second Event is cut/copied . Then If I run it separately again it still does the right thing to the third event… and so on

But I dont want to run the Nested Macro individually … it has to repeat dozens of times.

So I actually repeat it ( step 2 ) in the main Macro … thats why I nested it.

So my final Macro goes like this ( for 3 iterations )

Step 1
Step 2
Step 2
Step 2

But this doesn’t work. I looks like the first Cut event ends up at the second marker then it stops.

To my mind repeating the step 2 macro inside another Macro should produce the same result as manually triggering Step 2 Macro several times in a row.? Thats not what happens.

Nuendo 11 .0.1 / Mac OS 10.15.7 /

I think there’s macro problems … let me know if its me though!