Problems with return to hub, DORICO for Ipad 2.4

Hello,
Can anyone help. I am finding that after editing a file in Dorico 2.4 for iPad that was originally created on a Windows laptop, the return to hub button is not working, and I may also get an error message “Operation not permitted Error creating zip file: /var/mobile/Library…”
This happened using both Dropbox and (just this moment installed for Windows) iCloud to transfer the file. For all I know it could be a file permissions thing rather than a Dorico thing. It’s a little while since I used Dorico on iPad, so I am not sure if this issue is specific to 2.4 for me. Anyone else with this sort of issue?
Thanks very much,
Geoff D.

I cannot help sorry, but have the same problem on my iPad (unrelated to Windows), where I have the same error message.
I managed to find my files (In my iPad, Dorico) (previous to v2.4) and save them elsewhere, and in the end, uninstalled then downloaded Dorico again hoping to move, transfer, copy files (to hopefully use my iCloud Drive instead) but no songs appear there, so back to the internal storage but … with the error message. I was not going to report this yet, because I am unclear the exact steps I have done (in all the frustration) and not clear what is happening at all.
Now I see it is not only me, Geoff, it might be the same or related problem.

Thanks for the reply arco - sorry you also have problems, but it helps to know I am not totally on my own here. I think I will need to find an alternative short term solution (needed for the weekend), but I’m sure it will be sorted before too long.
Geoff D.

I have gone back to my laptop Dorico for now. Hopefully will have more time to investigate later, or someone has a procedure that works, might be quite simple :slight_smile: I had the idea of creating a new document, copy from the old, paste in new and it would work for subsequent savings, but not tried it yet.

same problem here on an ipad pro using files from the icloud drive

I seem to have made some progress. If I can remember what I did correctly, uninstalled Dorico again.
Deleted my Dorico folder I created in iCloud from the previous install tests.
Installed, rebooted;
Dorico Prefs>General set to iCloud for default save;
created a file, added some notes, top left tap to exit;
Rebooted, opened Files and saw the Dorico folder having been automatically created with the file in.
Moved some other files (from Mac) and elsewhere in iCloud to that Dorico folder;
They show within Dorico and seem to open and able to edit and save with the changes.
No other problems so far, files seem to be able to be edited in the Dorico folder.
Probably other checks to be done, but I am able to tentatively continue with the project.

1 Like

Thanks for the info - currently back on laptop trying to be ready for a rehearsal in a couple of hours, but will have another go at the iPad later.

I have a similar issue

I have all my files in a folder that I created for my dorico files in icloud. And now when I open a file directly from that folder, opens the file but when I close it and want to open it again from the HUB I mark “error” instead if I select the option open or import file opens it but I get this message at every moment being impossible to work, and after a while the screen goes black

Hi, I have tried combinations of deleting Dorico, re-installing etc, including following the steps described by arco (thanks @arco) earlier in this thread as exactly as I could, but so far this has not fixed the problem for me. (Along the way I never actually got the Dorico folder automatically created on the iCloud drive, so that differ from others experience). So it seems at the moment I just can’t use Dorico for Ipad at all with files shared via the iCloud. Maybe I need to read the documentation more carefully.
I know there are now other threads now with possibly similar issues so I will keep an eye out - but so far I have not found a solution for my problems.

@geoffD, where exactly is the project you’re trying to open? Is it located inside iCloud Drive, but not inside Dorico’s own folder?

Hi @dspreadbury . It’s inside the iCloud Drive- I don’t seem to have a “Dorico’s own folder” visible to me (via either the files app, or on the iCloud drive on my Windows laptop); I know others have talked about it being created automatically, but not (so it seems) for me. It must be there since if I create a file in the iPad, and have it saved to the iCloud drive then I seem to be able to edit and exit from it, with everything working as it should- I just don’t see it (or a parent directory) when I try to explore the iCloud drive.
I’m afraid I am not all that familiar with Apple style operating systems though, so don’t know much about visibility properties.
Thanks for the reply.
Geoff D.

No worries, Geoff. And the problem you experience is that after you open the project, you sooner or later see an error telling you that it can’t write the file? If so, then we’re working on that, and we will hopefully have more news about it in a day or two.

Excellent - Thank-you @dspreadbury. It does sound exactly the problem you are already on. I’ll watch out for that.
Thanks,
Geoff D.

I’m also experiencing this issue with a file opened directly from iCloud Drive. The message doesn’t appear when working in Dorico, but as soon as I switch away and then switch back, it appears reliably. After the message has appeared, it also becomes impossible to return to the hub.