Problems with Soft-eLicenser and Cubase LE 7

I’ve recently bought a recorder which came with a license for Cubase LE 7. I followed the steps to download the product and registered it into MySteinberg account.

There, it lists my download access code and an activation code, saying “Not yet activated”.

Initializing Cubase LE 7, it prompts me if I want to activate the product or follow the trial period. If I press Activate/Register, it returns a connection error, which makes no sense since I have all sorts of things running in the internet on the background. I tried it two days later, thinking it was a server issue and the same error came up.

Reading more instructions, I found out I could try activating via the Soft-eLicenser, but I get the following error “This Soft-eLicenser number is not valid”, which does not make sense. As I know, that number is unique and depends on the machine. It’s not logic to have an invalid number because this is a new computer and the only time I tried to use the eLicenser was now, attempting to register Cubase.

I CANNOT have access to support, for some reason, as well. If I press “request support” in MySteinberg page I go to an infinite loop of Steinberg pages stating how I can have support, but, apparently, I have no rights to e-mail support.

As a last note, attempting “Maintenance” via Soft-eLicenser gives the same invalid number error and states “try MAINTENANCE again to solve the problems”. Well, the problem came WITH maintenance and executing it again gave the same error.

I thank any reader who read this through and might solve my troubles.

Have a good day.

I can help you with this. What specific operating system and version are you running?


I’m working under windows 8.1. I’ve just installed the newest version of the eLicenser, as suggested, and the same error occur, during maintenance phases 3 and 6(if I let it continue). I’m my very first try (a week ago) attempting to register the product, I didn’t do maintenance (why would I do maintenance in a freshly installed environment??) and input the activation code given, which is valid, but it doesn’t proceed because it tries to reach the internet and check if my number is valid… which falls into the current problem mentioned.

Trying to register via Cubase LE 7 gives error 1003, which I think is a false-positive, since I have no problems connecting the internet during the process.

Thanks in advance.


Sent you a PM.

Dear Jeff,

I’ve followed the instructions via PM and the problem was solved.
My Cubase works as supposed to and is now activated.


im having the same problem as DanBc can you help me out

im having the same problem i need help!!!


I sent you a PM.

I sent you another PM.

hi, I have exactly the same problem, i am using windows 8, could anyone please help me? many thanks

Hi There,

I have the exact same problem, I have been struggling for two days. Tried turning off the firewall, synchronizing the internet clock, downloading the latest elicenser but still the same error saying - cant connect to the server, there is either a network problem or the server is down for maintenance…

I am using a Windows 7 PC and trying to get my Cubase LE 8 to work, thanks for your prompt response.


Can someone please help me out as well, I seem to have the same problem. I even created a specific thread with the issue but still awaiting help…

Hi, i have 8.1 and also the same issue, i would love this precious help please ! :3

Hi, i have 8.1 and the same problem, pls. could anybody give me the help? PM is fine, too. Thanks a lot.

can you please send me the code as well I am running windows ten and nothing seems to be working

I’m having the same issue with Cubase Elements 8 Full Version.

eLicenser says i’m not connected to the internet, but i have access all over, including this site…

UPDATE: I got past the firewall issue but now eLicenser says my activation code is not unique and I can’t use my software. THIS IS MY NEW ISSE. :frowning:
Any help is much appreciated!

eLicenser version
Windows 7 64 bit


Just bought the UR 44 and can’t load the Basic FX suite. Using Windows 10.

I am having the same problem please email me I cross my fingers

Hello, I have the same problem with Soft-eLicenser, I use win7, I tried to bypass firewall without good results…
please can you help me?