Problems with updating cubase 4/5 to 7 and soft e-licenser


Having problems with updating Cubase 5 to Cubase 7.

I’ve upgraded my PC and uploaded Cubase 5 to the new system. If I remember correctly, the Cubase 5 was not registered (is it too late to this now?) I have the dongle, which the system seems to recognize, as I can open the Cubase 5 after the installation. As I’ve bought the update pack for Cubase 4/5 to Cubase 7 and have tried doing the update. The update process seems to work but then I cannot see the link for Cubase 7 anywhere and I was not asked to enter the license.

I downloaded the latest e-Licenser, which seemed to be installed (it displays 12-digit dongle number), but it did not display any text, only empty boxes. I’ve tried entering the new license which came out of the box using steps from memory, but the e-licenser did not seem to recognize the key and a red cross appeared on Cubase 7 after entering the license key. As there is no text at all, I’m not sure what the problem is or if there is something i’m not doing correctly.

Would really appreciate any help or advice.