processor drain

Wavelab 10 is really beating up on my processor. Is anyone else having this experience and is there a workaround?

What is your configuration? And what is the symptom?

I’m on Windows 10 Professional. 8.5 works fine with the same plug-ins loaded.

What plugins? Where there are used? What is not working now?
What audio device and asio block size?
Are you using WaveLab 10.0.10?

It’s the UAD plugins that spike Wavelab. And when i try to process I get the attached message.

I have the RME Fireface 802.

None of this behavior happens in Wavelab 8.5 so it really can’t be blamed on the UAD or the RME hardware.
Wavelab-UAD.PNG

To prevent this message, use the same ASIO block size for both your UAD device and the RME device.
Also, make sure to use WaveLab 10.0.10

You can’t change the ASIO block size with the UAD software so i would have to lower the block size in the RME interface to match. Being that my processor is already at 100% this would be counterproductive.

I already have 10.0.10.

I’m really struggling to see why, as a moderator, you aren’t seeing this for what it is, which is a problem with Wavelab.

8.5 works perfectly with the same exact scenario without having to make any changes tio block size.

I guess that I will need to go directly to Steinberg.

PG is the inventor and main developer of WaveLab. You’re not going to get any more direct than this.

You can’t change the ASIO block size with the UAD software

Yes you can. See the UAD Console Setting on my Windows 10 machine:


Philippe

I have a PCIe card and don’t have those console options.

Regardless, I shouldn’t have to jump through all of these hoops.

Again, no such problems with processor overload in 8.5.

Looks like UAD needs to step up the drivers on their older units. How old is your UAD PCIe card? Perhaps WL8.5 is the max your UAD card can handle. It’s unfortunate but things change. Contact UAD.

This message is displayed by the UAD driver, not WaveLab.
Now, the question is: what it the context to make it happen?
For example, if you launch WaveLab, open an audio file, then insert a UAD plugin and start playback, do you get this message? Else, when do you start getting this message?

Is this the current UAD-2 PCIe or the earlier (now unsupported) UAD-1 PCIe?

It is the more current version.

When I start playback on an audio file the CPU spikes and the playback is choppy. When I process the file a message pops up saying that UAD is running at 512 and that the other plugins are not.

Do you have the LiveTrack mode active in the UAD settings? If yes, you should try to disable it.
I guote some UAD manual:

Note: LiveTrack Mode is available exclusively with UAD-2 PCIe devices.
(…)
When LiveTrack is active, host CPU loading increases.

More generally, try to change some UAD settings.

There is a UAD thread on the problem you experiment, that started a long time ago (2012), and with other hosts. Maybe you can find useful info there.
https://uadforum.com/general-discussion/11895-requested-buffer-size.html

Actually, there are more threads on this “requested buffer size” topic on the UAD forum.