Product somehow deactivated

I have Cubase Elements 8.

It was successfully activated on a Windows 10 machine; I received the activation code on 4th July 2016.

Apart from Windows updates, I haven’t done anything to the OS, nor uninstalled the product. It’s exactly the same install.

My eLicenser shows that I have a license for this product.

My online account shows that I have a license.

But when I try to open Cubase it says that no valid license was found.

Can anyone help?

Make sure you have the latest version of the eLicencer software.

Run eLicencer maintenance.

Hi arkadye - did you get this issue sorted?
I’ve had the same problem - Cubase Elements 8 on windows 10. Mine went pearshaped on 10th Feb.
Tried downloading the newest eLCC, and installed it (twice) which hasn’t solved the problem… It won’t connect to the License server so fails when running maintenance tasks advised above.

Really getting frustrated with it now!

Hi all,

Apologies for not responding to this thread.

I’m not sure what happened exactly. I may have not had the latest version, and updating helped, but I don’t think I did anything specific to make it work. It just started working when I tried again the next day.

Sorry that this isn’t helpful to future people looking this up. :frowning: