Program Change not working at all 2.0.15

Installed 2.0.15 today and now the ProgChange ist not working at all. when i hit stop and play it switches, this is no option for live …
(sorry to say but, i’m not sure if this software is getting better or worse)

Andi

… I can understand your point of view. We are doing our best.

/Michael.

2 Likes

thanks for answer,

but it worked well with 2.0.14!. I didn’t change nothing, same usb, same cable, same everything … i cannot comprehend whats wrong …

Andi

That is quite vague. Presumably you have programmed PGM CHG on a track and want it to be sent…when? At start, or at positioning in the timeline? Did you check preference “Chase on Start” and try both options? Do you have a Layer possibly also sending PGM CHG?

Tried like so:

  • new project
  • add MIDI track
  • output to Virtual MIDI 3
  • dbl click create new event
  • select and open in MIDI List Editor
  • select pgm chg and insert at 1.1.0
  • open MIDI Monitor
  • Input Virtual MIDI 3
  • locate, play, all works as expected with or w/o Chase on Start.

Does this work for you?
What do you do?

Like i posted here:

i reinstalled 2.0.14, here it works …

Andi

Got that. But does the above sequence not work in 2.0.15

I just updated to the 2.0.20 maintenance release from 2.0.14 and now my program changes sent to my VSTis don’t work.
Following the procedure you specified has the program change showing up in the MIDI monitor but the programs still don;t change.
Downgraded back to 2.0.14 and works fine.
This is not user error.

1 Like

If you send to any other destination but the Midi Monitor port, the events should be “showing up” at that destination in the very same way.

Just to exclude the problem in the prior post of MIDI Editor placing data to the wrong destination: check with MIDI List editor. What is shown there is sent, and that can be monitored with the MIDI Monitor. But maybe still missing something, there are many tracks in your video, maybe try to reduce and narrow…trying to help but cannot reproduce something.

Devices here respond well. Also maybe try to replace track output with a Halion Sonic, and set that to “GM Mode” in its Options. Does it change programs?

This is much worse than I initially thought. I got fixated on troubleshooting the Program Changes but on further investigation, nothing sent to a Virtual MIDI port gets through to the VSTi. Hardware ports work fine.
The MIDI monitor shows the events but they don’t reach the instruments.
I’ve tried all the Virtual ports and none of them work.
Going back to 2.0.14 everything works as it did.

I’ve been a heavy MIDI user since 1986 so I do know about ports and channels so please don’t infer that this is user error.

I have Halion Sonic, Omnisphere and Wavestation set up in Global Layers each addressed by a separate port with Program change enabled on the appropriate channel.

I am putting a program change in the part layer which is sent to the appropriate port. I have tried with MIDI chase enabled and with it disabled.

Up to, and including 2.0.14 when I switch parts the correct programs are selected on the instruments and I am able to play those instruments.

In 2.0.20 and 2.0.15, which I have now tried, this does not work.

Don’t know what you do, you need to narrow this.
Tried the very same sequence I suggested (with the new version to come, but no chage in that area anyway):

For PGM CHG I set both data to 1.

Then create Layer 1 if not yet present, set output to Halion Sonic, and input to Virtual Midi 3. In Halion Sonic/Options/Edit, set “Program Change” to “GM Mode”. Then start, and Halion Sonic will switch to “Bright Acoustic Piano” which is pgm 2 (list editor counts from 0 upwards as defined by MIDI protocol).

Still no?

It turns out that if I turn off multiprocessing it works as before.
Bit of a pain but I can live with it.