Program selector

How does one dissable it? When I set the midi chanel to ‘Any’ I can see it appears to be taking info from Kontakt but why and where?

Hi,

Could you be more specific, and describe what happens, and when, please?

Thanks Martin
Using an instrument rack with a number of midi tracks routed. So, using midi ch 1 for the first midi track and ch2 for the second, and so on.
If I change the midi chanel to ‘any’ then a different sound appears as shown in the program selector.
Is there anyway to turn this off?

In the top image track 1 plays ch 1 etc.
If I change basses midi ch to ‘any’ then the sound played and the program selector change to the cello on ch 2.
Same thing if I change the violins.
There is no dropdown list in the program select, only cello.
Can this not be disabled?
prog_select_combine.jpg

If you have it all set up for each track to play it’s own midi channel, why are you changing it to any?

What are you trying to do now changing to any?

I’ve never used any ch on the output, so not sure what you’re trying to get.

Also have you tried this with other instruments?

It may be something Kontakt is doing…

There is definitely an issue. I just realized, there is something similar with using HALion Sonic SE.

Thank you.
And the reason for changing to ‘any’ is that when in track edit you can select certain notes and change the channel of them, so changing from legato to short or long articulation can all be done from one place and one score if needed.
Given that 8.5 is out I guess the idea is for me to upgrade?

OK, I see an upgrade path to Elements 8. Has this issue been addressed

I’ll take that as a ‘no’ then.