Project Cursor moves when selecting a region - How do I stop this?

I must have accidentally hit an option somewhere but I can’t figure out what. Whenever I select a midi or audio region, my project cursor moves to the beginning of the region - very frustrating when trying to edit midi and the playhead keeps moving. Could anyone kindly point out how I can disable this? :frowning:

check if “video follows edit” (or similar, mine is in Spanish) is selected in the transport menu. I had it On without realizing it and drove me mad til I found out.

Video Edit Mode is on turn it off