Project Template Input Assignment for UR22 Mk II

Good Day to All,

I’m am an absolute noob when using Cubase LE; it is my first venture into interfacing a microphone and guitar into my Mac Book Pro via a Steinberg UR22 mk II. I have noticed that the descriptions for the Recording Project Templates in the Steinberg Hub have instructions for connecting your guitar into Input 1(Hi-Z). However, the Steinberg UR22 mk II Hi-Z input for guitars is Input 2.

Is there way to edit the template file so that the inputs are reversed, or do I have to modify the inputs every time I use a template?

Your assistance in this area would be greatly appreciated.




Basic Steinberg UR22 mk IISetup
Mic connected to Input 1
Guitar to Input 2

What I did was simply swap the input routing around:

From this


Awesome the Guitar is being routed to the correct channel

However, for the Vocal Channel
From this

To this

Resulted in nothing:

However, as can seen the vocals are getting in.

Now when I delete the Vocal Channel and create a new Audio Channel with no Track Presets

All is good

Now when I add a Preset

The Mic I/P no longer works.

Now, for the interesting one, if I disable the inserts

Tata Daaa, it works

I then re-enabled the insert after swapping A/B, and it works now and then.

I’m at a loss on why this is happing.



I’m at a loss on this one.

Cheers again

Basically you are going to open a template, set it up as you wish, and before recording anything save it as a new template using the “Save as Template” function in the Cubase file menu. Save it with a different name so you don’t overwrite the original Cubase template (unless you want to). Then use that template when you start new projects and it will be already setup as you wish.

A thought for the other issue…

  • Make sure that the vst is not “bypassed”. Meaning, you picked an insert as shown in your photo but, have you actually enabled it. You can click on the “e” edit button and then double click on the insert name which will open the vst. Then you can make sure it is enabled and not bypassed or muted from there.

Regards :sunglasses:

Thanks Prock,

The VST was enable; I was able to see the signal being inputed; however, on the mixer screen no output. After clicking the AB button in the VST, all was good.

I have no idea what this button is; however, it did do the trick. Maybe outputting to a different bus.

I thought that Cubase would I have set up the record templates based on device that is being used.



Hi, did you resolve the issue? I just bought the ur22 mkii and I’m a noob with cubase. Can you reupload your pictures or solution if you got it? I would greatly appreciate it. Thank you.