Proper audio engine: Gapless Audio!

did Steinberg ever discuss this issue in this forum? I would really like to have feedback on this request.

+1

I never thought about this as a feature request, but I do agree that it’s annoying lol… sometimes I specifically hold off on adding a track or whatever because I don’t want the audio to pause/skip lol… so +1 to this. I’d vote for it if I hadn’t already used my 3 votes.

1 Like

believe me or not. I wrote about this issue when I bought version 4. :woozy_face:

3 Likes

at this point it’s really embarrassing for steinberg to not solve this issue in cubendo. such respected programs that used by many and one of the inventors of DAWs.
i think its should be steinberg’s first priority to fix this for their programs and their users/customers.
the only DAW of the serious ones that still have this audio gaps.

+1

It’s pretty bad that this feature still isn’t here, this is my all time biggest gripes with working in Cubase

I get audio “gaps” even by clicking on track events.
very annoying…

but, if they’ll fix this they will probably break 10 others things…

+1
It’s more like a nice to have for me, but sometimes it really is annoying.

  • 1 !!!

+1 with proper PDC, if possible!
That would set the DAW apart!

Steinberg ,you can do it!

Demoing Cubase 11 after years in Studio One and Pro Tools and I’ve got to add my vote to this one. I read this thread while downloading the demo and figured it would be a mild issue, but it’s surprisingly annoying. Probably not a dealbreaker but something I’d really appreciate getting addressed.

Example: One of the most common operations I’ll do while playing back is add an empty audio track and drag an audio file onto it to layer drums or add little samples for fills and variation. Just adding the empty track causes the audio to skip. Then if I don’t like it and want to remove it, another skip. Gets old.

+1
I’m on 11.0.3 Pro.
I don’t remember the gap being so lengthy/disturbing simply adding another output from a VSTi.

The length of the gap depends on overall project latency and buffer size, so in some songs it’s unnoticeable and in others it’s huge.

It would be better, however, if there was no gap at all. Even other dual buffer programs like Logic, PT, and S1 with Dropout Protection don’t have gaps when adding/removing tracks etc.

It’s very likely the problem is with the interface between the GUI part and the audio processing part, rather than the audio engine itself. Eg, the audio engine they have could probably be upgraded without too much effort to support glitchless reconfiguration. However, I think the GUI code they have, is the problem.

Because plugins need to be notified about changes in configuration with the real-time processing “turned off,” I would think they stop every plugin, then makes the changes, then start every plugin again, and that stop/start means you get a glitch.

The benefit to this is that they can make changes to the audio processing graph from the GUI thread, without worrying about moving/deleting buffers that are in use by real-time processing; thus they will have fewer crashes, and better plugin compatibility.

It would be possible to calculate which plugins would only need to be re-configured (if any!) when making changes, and only stop/reconfigure those. It would also be possible to make all audio graph edits by sending real-time messages (including new pre-allocated buffers and such) to the audio engine, asynchronously. This would, however, probably require significant re-arranging of how the GUI interactions work in the host application, and thus, my guess (based on experience from writing other music software of various kinds) is that they have chosen to live with this problem, because the necessary changes are too much work for too little gain.

Ok, I’ve seen other DAWs look like they were going to “live with” their particular issues as well, right up to the point they fixed them. So I voted on this and hope they improve it.

1 Like

If they’re chasing the EDM market like some believe in recent years then they have to get gapless audio in place. Last thing you want when jamming out a loop is for it to keep stopping, if you’ve got any outboard gear in sync that all goes out too.

Personally, it’d be a nice addition for me, but kinda used to it now and not an issue. But I can see how it has a negative effect when you first use Cubase, it initially leaves the impression that the DAW is struggling even when you’re 3-4 tracks deep.

2 Likes

Just adding a Note(a track actually !)
Protools, Abelton,Logic,Studio one,Reaper, cu-bbb–aa–ssse, Nu—eeen–doo

1 Like

The number of actions that cause gaps in steinberg’s engine is just incredible.
The latest one driving me nuts is turning a bar line in a score, to a double bar line!!!
How on earth is this effecting audio playback?

1 Like