Hi. I have a UR824 interface. Can someone please post a screen shot of how the VST CONNECTIONS should be set up? I am using Cubase Pro 8 with VST CONNECT Pro 3. I am the engineer.

My problem (well, one of my problems) is this. I am hearing my scratch tracks in real time, as opposed to the performer’s on delay. The performer is my bassist. So to me, the bassist is playing behind the scratch tracks even though he is hearing them fine and the recording is fine.

When I was using my CI2, this all seemed ok. I heard the bassist in time to the scratch tracks as he was recording. So I assume there is something unique to the UR824 versus the CI2, and it has something to do with the Control Room/Studio settings.


Did you try an empty project, then simply apply project menu/VST Connect/Create VST Connect?

Hi musi. Thanks. I ended up getting help from Chris at USA tech support. It is still frustrating but working much better.
I have been testing it by using two of my PCs on my home network. Desktop/UR824 and Laptop/CI2. Plus I installed the 3.0.4 updates today for both or and Performer and worked with it some more.

Right now Chris is helping me figure out why I am not getting any reverb on the performer’s side.

And also, I am unsure if he ever helped me get a talk back working (the performer’s talkback). This process has become a blur and the project I saved that he helped me with became corrupted. I know I am supposed to be able to go to PROJECT>VST CONNECT>PRO and choose ADD TALKBACK CHANNEL but this option has been greyed out (unavailable to choose) every single time I have tried to add it. Even after I updated today. I don’t know if this is related to the the CI2 or what. I can set up an audio track but am unsure if that is the proper workaround.

So please let me know if you have any thoughts about why the ADD TALKBACK CHANNEL option is never available for me to use.

A common mistake is to not see and move those tiny send faders on top of the channels. We will enhance their visibility in a later version.

Sorry I don’t quite get that. You say “the performers’ talkback” which I find confusing.
You will hear the Performer thru the VST Connect plugin (and the VST Connect Monitor plugin in the Control Room Monitor), provided his mic is connected to one of the Performer channel inputs.
The Performer will hear you thru your Control Room (“Studio”) Talkback Channel. If “Add Talkback Channel” is not offered, that means you most probably already have a VST Connect Talkback channel in the Control Room (you should really open the Devices/Control Room at least once to see all of this). If the performer can’t hear you, make sure to have your TB mic assigned to that Channel (Devices/VST Connections/Studio/Talkback).
I keep repeating that aside from the latter assignment, all you should ever have to do to get VST Connect to work is to activate Project/VST Connect/Create VST Connect. Try with an empty project. Does it not work? If not, what’s missing?