PSP Audioware Twin-L vst effect crashing Cubase

Is anyone here able to run the VST3 version of Twin-L in Cubase 9.5 or 10? Just curious. Please check the version of the plugin you are running before posting as the installer also installs a VST 2 version. I am interested in VST3

Tech-Dance - Carvin Man - it’d be helpful to others if you included your computer setup in your sig.

Done

Hi,

no problem with any of PSP plugins here

And to clarify you don’t work for PSP Audiiware and are running Twin-L and the VST3 version installed. Please check it is in your VST3 folder

I’m not certain of enough clarity in your request…
Anyway… It is as I stated but I run Cubase on Win7, maybe that’s one of your problems.

cheers


trito

I’ve found the VST3 support from PSP not mature yet. In my particular setup, Vintage Warmer 2 VST3 is also misbehaving, with very long starting times. If I were you, I’d stick to the VST2 versions for now, until PSP iron out the bugs.

No probs with Vintage Warmer 2 or any of my PSP Audioware plug ins other than the VST3 version of Twin-L here. I agree the support hasn’t been great so far but the guys at PSP seem to be suffereing from from jet lag from being at NAMM in North America. NAMM finished a couple of weeks now however! My current advice to everyone is to try out the demo before placing an order for this plugin. The VST 2 version of the plugin thankfully works fine here. Make sure you’ve activated the plugin in the latest iLok software. It didn’t make a difference here but has apparently worked for some people and should be done as a matter of course anyway.

I agree. I also own several PSP plugins (Noble Q, Echo, SpringBox, Vintage Warmer 2). They all have been working flawlessly for years in their VST 2 versions. The only one that was recently updated to VST 3 was Vintage Warmer 2 and, as I said above, Cubase doesn’t seem to like the way the VST 3 port was implemented (it hangs for several seconds when instantiating the plugin). However, the VST 2, which also uses iLok in this latest version (2.7.3), still works fine.

With Twin-L it hangs and hangs forever in my case! Until I hit CTRL-ALT-DELETE that is!

In addition to my previous post…
I use almost all of PSP plugins both VST2 (because of past projects) and VST 3 - for the present ones and never encountered any problems. I don’t use iLock key versions though.

Tech-dance, I really dont’t want to force You to use Win 7 which is sooo old (but serving me well), only inform You about it. So: no problems witn VST3 but in Win7 and I’m not affiliated with the PSP company maybe except for country of origin… :wink:


cheers and peace

trito

I have no problems in Windows 10 (64) running VST3 plugins bar Twin-L. This is a very odd one! And trito I take it you are from the land of that lovely fellow Mr Tusk, Poland! If you see him thank him for his kind words about the UK recently :slight_smile:

He’s still Your fellow until Brexit… I don’t get Your point of view, so sorry, be safe.


cheers

trito

What is your perception of my “point of view” trito?

PSP updated PSP Twin-L to version 1.0.1
Maybe all your problems will be solved…

Thanks Mr PSP :slight_smile:

You welcome, Mr Brex-dance :wink:

Brex-dance - I love it!