punch in/out problem


I followed all the steps in the manual for punching in/out, but I don’t hear the monitor when the recording is enabled for the punch in point. On the track I’m punching in, I need to hear the playback before the punching in point, so monitor is off for the track and the record (red) button enabled for setting up punching/out. I’m expecting the monitor button to come on once the punch in starts so I can hear myself play, but it doesn’t. Is there a setting I’m missing?
My workaround is to duplicate the track and record on the duplicate track and move into the original track after, but this is time consuming.

Windows XP SP3
Cubase 5.5.1

Preferences - VST (I think) - Monitoring - tapemachine style

That worked, thanks a lot