Punching MIDI wipes previous bar - RESOLVED

Hi. Ive run into this before and unfortunately i do so little MIDI i cant recall the answer. When recording piano in particular, when i punch in it wipes a second or 2 before the punchpoint. Its very frustrating. Im sure its some simple setting I’ve forgotten about. Im on my lowest buffer setting 48. Ive had this happen with both internal vsti and midi from an external synth.

Thanks for any help with this!


Nothing? I’ve had this problem for a while. I’ve seen it come and go actually. I guess I’ll put in a ticket or something with tech support. I’m about to do an album with a piano-based artist who uses a MIDI keyboard. I have to get it solved somehow.

I just know it’s going to be something embarrassingly simple or I wouldn’t be the only one experiencing it, but at this point I’ll take the shame just to get it solved :slight_smile:

Sounds like the record mode is set to “replace”
There are settings for this on the transport bar if you haven’t customized it.

I think you want “Mix” as the record mode.
I haven’t had to change these settings in quite a while so my memory may fail here.

Once you get it set correctly, make a template for your piano recording project
with these settings in place.

Much Thanks! It is set to replace. I’ll try out Mix. I basically just want the MIDI to record as if it were audio.

Hi, I tried all the different settings and none of them fixed things. I need to have it on replace if I’m punching into existing material. And I’m still experiencing Nuendo wiping the bar previous to the punch.

Hi Hopetown,

Do you have any retrospective record settings on?

Also, when I punch in and play an early note Nuendo will automatically adjust to capture that note. Try starting slightly late on the beat.

Let me know if you find an answer to this.


I realize it seems obvious and I feel dumb about it but it wasn’t retrospective record, it was the preference check box for “Snap MIDI Parts to Bars” - I could complain about WHY such a function would be on by default but I’ll just assume someone else has a good use for it. For me, all I want is the MIDI to record the same as audio.

Thanks again for helping me with this issue. It’s one of those things that rarely comes up for me, but when it does it’s horrible!