Q-Link creates wayyyy too many sends!

I don’t know if this is a bug or not, but if you:

  • Open MixConsole
  • Enable Q-Link
  • Select any number of tracks
  • Right click on a selected track and selected “Add an FX Channel to Selected Channels…”

You’ll wind up with a matrix of sends where the width of the matrix is equal to the number of tracks you’ve sent, and the height is equal to the number of tracks you’ve sent multiplied by the number of FX returns you’ve created.

I can’t tell if this is a programming oversight (which could probably be fixed by creating the necessary number of sends before activating any/all of them?) or if this is an intended feature as working (in which case, I’m wondering if there’s a way to turn this functionality off - it’s an obnoxious number of clicks to get them removed.

Hi,

I get only one Send in this case. Cubase 8.5.20 on Mac OS X.

Yep, I’m on Windows - it does this to me too.

Then it seems to be Windows only. I will check tomorrow on the Windows side, and then report it as a bug.

No, look at all the responses, there are Mac people, too. It happens to me sometimes and I’m on Mac.

Thank you! :slight_smile:

Sorry I probably do it wrong, I cannot reproduce it even on Windows 10 (Cubase 8.5.20). My repro:

  • Add 4 Audio tracks.
  • Open MixConsole.
  • Select all 4 Audio Tracks.
  • Enable Q-Link.
  • Right-click to the one of the Channel, and select Add FXChannel to Selected Channel.
  • Keep the default settings in the Add Group Channel Track dialog (Count = 1; create inside folder).
  • Click Add Track.
    => One FX Channel is created and all 4 Audio tracks are routed to this FX Channel via Send.

What’s different in your scenario?

This is what happens when I create 16 tracks and add an FX channel to it.
New Bitmap Image.jpg

I see, I got it now, and I can reproduce it. Thanks!