QC knobs only working one direction

Hi all,

I’ve recently been learning cubase 11, connecting it with the M-Audio Oxygen pro 61 controller. I have a problem with track QCs. Though I successfully assigned the knobs on my keyboard to different quick controls, they only work going clockwise, when I go counter-clockwise it immediately resets the value to -100 i.e the lowest and then I have to climb back to the value I was at. I’ve searched high and low for a solution but can’t find any. All channels are flagged RTR and there’s no setting I can find that allows me to change this - I’ve done the reset/learn/apply loop a couple times. It means I can only use the knobs going “up”, rendering them pretty much useless. Anyone know what’s up with this?
Thanks

The second ‘R’ stands for relative, which is meant for 360 degree encoders, not the standard potentiometers your keyboard uses.

Click into the flag field on each lane and then onto the ‘Relative’ to uncheck it.

The manual says:

Flags

Allows you to select one of the following flags:

    Receive

    Activate this if the MIDI message should be processed on reception.

    Transmit

    Activate this if a MIDI message should be transmitted when the corresponding value in the program changes.

    Relative

    Activate this if the control is an endless rotary encoder, which reports the number of turns instead of an absolute value.

Not sure about Receive and Transmit, I guess you have to try it out…

Thanks for your reply. I did already try that, but what happens is it turns the knobs into behaving like switches…I turn it the full spectrum and get two different, seemingly arbitrary values, like 0.8 and 51.2; turning the knob just oscillates between them, there’s no in between!

I only have controllers with endless encoders so I can’t try it out but I think only having ‘Receive’ checked should do it…

appreciate the help but that doesn’t fix it

I see your keyboard has a automapping function for DAWs. Did you try to switch this off first?

How would I do that? Under devices (in CB) I am using the Mackie Control option, which doesn’t have any auto mapping option. Would it be on my MIDI controller or is it an option with CB?

I didn’t and don’t want to read your keyboard’s manual but from the M-Audio website it looks like you can switch it on and off.

You can also disconnect the Mackie temporarily in the devices setup (just select ‘Not connected’ as In and Out).

1 Like

I also suspect that you can’t use the same device as Mackie Control device and as Quick Controls device.

Configuring a device as Generic Remote opens many more flexible possibilities.

hey, so, good news…when I changed the preset on the midi controller to “user DAW”, now the knobs work properly. Kind of weird because you would think it would be correct to use the Cubase preset, which I was. But I guess a USER DAW and using a Generic Remote offers more customizability. Somehow I feel like I’m going to run into some problem by using that USER DAW preset, but so far so good. Thank for the help, appreciate it.

1 Like