Qcon Pro X Mixer cubase.5/9 issue.

Hi there,

I have an issue with my secondhand pro x running 1.14 firmware…

I have it connected,setup using mackie control,and working with my win10/cubsase 8.5/9 pc. My specific problem is when I open an existing Cubase project , or load an empty project, and add multiple tracks, the pro x randomly jumps between all the available tracks, rather than staying on the current selected Cubase track. This does not happen in cubase with the pro x switched off. Can you help me resolve this?

Assuming the most current firmware version is installed in the ProX, and you have trashed Cubase preferences and rebuilt, I would contact Qcon support.

You are in Mackie Mode, the only other options to check in Cubase would be to confirm you get identical behavior with both Cubase mode and compatability mode. Also try another usb cable and avoid any hubs.

Second hand? Icon didn’t even start shipping until just a year ago. Has it ever worked correctly? Have you tried it with another DAW?