Quantize works, but notes show as slightly early

Perhaps I’m doing something wrong, but I’m seeing that my quantized midi track has all the notes shown slightly before the start of each count/bar, by a small amount that is less than my quantization choice (1/16th).

Is this an expected outcome in any scenario? Or is it some subtle bug related to time code? In this particular project I made an audio recording of some song, then adjusted the BPM (which doesn’t affect audio, just to get the click track to match the recording), then recorded some midi, and then applied quantize to the midi track. I expected the notes to align with the time bar, and they almost do, but not quite. :confused:

Hi Pitchy,

Thanks for your message.

So far we are unaware of quantize issues in Cubasis.
Please provide us with a short video clip that shows all steps involved, and share the download link via private message.


Thanks for the response, I’ll try to take a video of the problem later today. I’m not sure if I can reproduce all steps that caused it, but I do think I can show your a track where quantize moves the notes slightly foward, off the beat. I was able to reproduce it just now, but weirdly it doesn’t happen on all midi tracks. More to follow.

Hi Pitchy,

Thanks for your update.

Please provide me with the download link to the clip via private message, once you’ve captured it.
The more detailed steps are visible and/or audible, the easier we can give it a repro within the team to evaluate the issue.

On a side note:
It might make sense to give the latency settings (Setup/Audio/Hardware Latency) a closer look, to see if they will contribute to better results when recording MIDI, before making use of quantization.

Hope that helps.


Turns out the problem was that the quantization uses the start of the clip as the reference point, rather than simply quantizing to the beats/bars of the song.

Perhaps I had manually trimmed the left edge of a midi recording with ‘snap’ off, meaning the clip didn’t start on a beat. Or possibly I tweaked the bpm ever so slightly after recording a midi section. Either way, applying quantization to that midi clip moved/quantized all notes relative to the ‘off-the-beat’ start of that clip, putting all notes in that recording slightly off the beat.

Took me a year to figure it out, but there it is! :slight_smile:

Obligatory praise: you guys are knocking it out of the park with Cubasis and with the customer support! :thumbsup:

Thanks for clarification, Pirtchy!