Quantized MIDI note is not quantizied

I don’t understand what’s going on here, haven’t had this issue with previous versions.

I quantized note to fit bar #34 and it looks like it begins at 34 in the midi window but in the main window you can see notes begin before 34 and if I cut the part at 34 the notes get erased.

If I move the part to the beginning of the track, it gets white out’d and says “too large” and asks to leave as is or cut it

.

Hi,

Are you sure, it’s the given track? Have you tried to Zoom In/Out to force redraw?

Yes, it was the only midi track in this project when I had this occur (those two audio tracks is all it had besides the midi).

I went back and forth opening/closing the window several times and even restarted Cubase to see if this was a glitch or some new “musical quantize” option I was unaware of that got turned on by default.

I fixed it by manually dragging each note in the chord to the right to snap on the next grid point and back to 34 where it got snapped properly.

It appeared as though the notes only got quantized visually in the midi window by Quantize function but didn’t actually get moved at all by it.