Question about MIDI channel assignment in the key editor

Within the key editor on the info line, there is an option to change the MIDI channel of individual notes. No matter what I do though, they always play on channel 1. How can I fix this? Basically, I’m using the key editor for drums and I want to assign different notes to different MIDI channels so I can control different instruments in a multichannel instance of Kontakt… I am trying to do all of this with a single MIDI track to keep it simple. It works fine if I create new MIDI tracks in Cubase and assign them to a different MIDI channel, but why won’t it work with a single MIDI track? Is “channel” in the info line referring to something other than MIDI channel?

Within the key editor, I highlighted all of my “kick drum” notes, and then hold down CTRL while entering “1” into the channel field in the info line. Then I do the same for all of the “snare” notes, but this time I enter “2” into the channel field of the info line… etc. etc. etc. The snares still only play on MIDI channel 1 of Kontakt.

Is this a bug? I am confused.


It sounds like you are using an instrument track, and that’s how they are ‘limited’. To use multiple channels in one track load the vsti into the vst rack (default f11) and use a midi track.

(edit: oops. And set the track midi channel to any. Merci Vic, danke thinkingcap.)

Or, alternatively, convert the MIDI Track to a Drum Track. Note by note MIDI channel assignments will work correctly with a Kontakt Multi loaded into an Instrument Track.

For that to work, the MIDI channel´s output needs to be set to “All”. Is it?

He means “Any”, but yes, that’s what you need to do.
You might also like to experiment with using Drum Maps :wink:

Yep, correct, thank you vic-france. I´m on german layout at the moment…

I think I had the channel set to “1” on the main MIDI track. I’ll try setting it to “all” when I get home this evening… Thanks btw! I hope it works…

You might also like to experiment with using Drum Maps > :wink:

This method doesn’t care if Any is assigned or not.