Question about Render in Place with multitimbral external instrument

I found a similar topic in an older posting, but I am not clear still. I have a rack instrument enabled that has 8 Audio-returns into cubase. When I select a midi part on a midi track that is routed to this instrument (sending signals on only ONE channel which will as a result only play sounds on a single return channel) and render it this results in 8 new audio tracks, 7 of them with silence. Is there a setting how I can prevent that?
Thx, Ernst


Unfortunately there is no way around.

The reason is Cubase doesn’t know about the internal routing in the plug-in. So Cubase doesn’t know, which Audio Return should be Rendered only.

I know, you can set the Audio Return Channel bellow the Instrument tab (Output tab) in the Inspector. But this information is not used for the Render in Place.

Many thanks, Martin!
Not a major thing after all - I will delete what is not needed - maybe a clever PLE will help doing this?


PLE cannot recognise, if there is silent (-oodB signal) on the track. I can’t imagine a way, sorry.

Thank you, Martin!

As a byproduct of my experiments I discovered that changing the outputs of a vsti (enabling or disablig individual outputs) and trying to render a midi track that is connected leads to a buggy behaviour - the latest enabled output is NOT rendered. It seems that enabling or disabling vsti outputs after having rendered once leads to a faulty behaviour of the rendering process.


Could you please write step-by-step reproduction process?

Yes, I can J

The project consists of 8 midi tracks. These are routed to an external vsti (Motif XF Editor VST). This is set up as a rack instrument. The midi channels receive midi from the keyboard, channel filtering is on and the channels of the outputs are set to 1 – 8. All return-Channels (output channels) of the vsti are enabled.

I recorded midi to midi track 1.

Select the midi part on the track

Select Render in Place

Result: 8 audio tracks are created, the first contains the rendered audio, the remaining 7 contain audio events with silence in them (as expected).

Now I disabled all but the first vst output (return) channels for the vsti.

Select the midi part on midi track 1

Select Render in Place

Result: 1 Audio track is created, containing the expected audio

Now I enabled outputs 4 and 5 of the vsti (so the total of enabled outputs is 1, 4 and 5).

Select the midi part on midi track 1

Select Render in Place

Result: 2 Audio tracks are created - this is the bug , the audio track 5 is missing.

This can be reproduced with any change of enabled audio outputs of the vsti (Motif XF Editor VST)

Regards, Ernst




Reported to Steinberg. Thank you.

Hi Martin,

many thanks for your kind support!