Question vst instrument

to record a vst instrument track. i start recording, I hear the instrument when I play with the instrument’s virtual keyboard, but it doesn’t record and when I stop recording the track is erased. i don’t understand.
Thank you.


Double-check the Preferences > MIDI > MIDI Filter. Make sure the Notes are not filtered for the recording, same as the MIDI Channel is not filtered out.

What MIDI Input do you use? Do you use All MIDI Inputs option? If yes, is your MIDI Device part of it? You can check this in the Studio > Studio Setup > MIDI Port Setup.

Is the track Record Enabled?

If you mean pressing the keys in the instrument interface - those will not be recorded. It’s for auditioning only.


I see. @misohoza is right.

If you don’t own hardware MIDI keyboard, use the On-screen keyboard in Cubase, please.

Thank you it’s very cool. Greatings