Questions about Note Duration overrides in Expression Maps


I’ve been puzzled about Note Duration overrides in Expression Maps. In the attached project, I’ve set note duration to 400%:

Duration Test.dorico (623.5 KB)

Here’s the music:

First, it would be great if the actual durations were displayed in the MIDI region, not the notated durations:

But even more perplexingly, it seems the rule is followed for eight and quarter notes, but not for whole notes (MIDI imported into Logic to see actual durations):

It’s a bit tricky to see, but what’s happening is that eighth and quarter notes have their durations 4x’ed, but the whole notes only have their last quarter note 4x’ed (they take 7 beats rather than 4). I was at first wondering if this had to do with the time signature, but that doesn’t seem to affect it.

The same phenomenon happens with small values of note duration (like 10%, rather than 400%).

Is this expected or a bug (or am I doing something wrong)? Less importantly, any plans to update the MIDI editor to show actual durations?


Already possible:

1 Like

Ah, super helpful!

But the question remains - why doesn’t it correctly handle the note lengths for whole notes (and other large notes)?

(Completely without having any special insight) my guess would be…
The options are intended to help tweak the response of different sample libraries, not make wholesale changes to playback. eg. Some libraries will trigger legato patches if notes overlap a little. So most changes to these settings are marginal to achieve the best result from each sample set. After all, Dorico is a notation program and there would be little point in providing notation that bore zero relation to playback.

Totally fair, @Janus.

To be clear, I am only using 400% and 10% to test / demonstrate the behavior. What I want is something more like 80-85% to handle a rather pad-like sample library (Arkhis). Once I couldn’t get what I wanted there, I started exploring the larger changes so I could better understand what seemed to be going on.

Either way, the behavior is counterintuitive (IMO) and not documented (AFAICT), so wanted to post.

OT @Derrek : I know that piece… :wink:

It’s been getting around lately. :rofl:

If I remember correctly there is a maximum amount of duration change which will be caused by the playback options. After all, if you have a very long note (say several bars’ worth of semibreves all tied together) then you don’t necessarily want an enormous gap at the end of the note.

Again, not trying to imply that 400% is a valid use case. I was only using it to demonstrate the issue because it’s hard to see visually when we’re using smaller values.

I was trying to cut a whole note down to 85%, but it seemed to only cut the last quarter note portion of it by 85% - so, in effect, 96.25% duration of the whole note. To get desired 85% cut, I would need to cut the last quarter note down to 40%. But this would mean a quarter note by itself would be cut down to 40%, which is not at all what I want.

Another way to cut a whole note down to 85% would be to set its playback end offset to -288. The playback end offset is measured in ticks, and there are 480 ticks per quarter note. The notated duration of a whole note = 4 x 480 = 1920, and the desired played duration is 85% of 1920 = 1632. The playback end offset = played duration - notated duration = 1632 - 1920 = -288.

Using the playback end offset to control the duration of longer notes would allow you to use the default note duration in Playback Options to control the duration of shorter notes.

It’s also curious that the max value is 400%.

Setting the grid resolution in Displayed Durations to various dotted note values shows that these “gaps” seem present and proportional in all note values: whole, half and eight notes. They also appear to change in the same proportional way at 200 and 300 as long as the resolution is at dotted value.

@dspreadbury do you mind opining on if this is a bug or just an under documented behavior?

I don’t recall the precise behaviour off the top of my head, but Richard is correct in his reply above:

As I recall, the effect of % value depends on the length of the note. For notes that are a quarter note or less, the effect is applied as a % of the full note length. For notes longer than a quarter note, the % is applied only to the last quarter note of the duration. So if you have a 80% setting on a whole note then it means that last beat is shortened by 20% (ie whole note length is 3.8).

As Richard says, the reason for this is that if you have a long note over multiple bars then it would be unexpected for the entire duration to be shortened by the percentage (a note tied over 10 bars would be shortened by 2 bars in the 80% case).

1 Like

It’s not a bug, as Richard has already indicated. We have a limit on the maximum adjustment to the note’s notated duration to avoid notes becoming absurdly detached. If you really want a note to be much more detached, then notate it that way. Don’t write a half note and expect it to be played back as an eighth note.

Thanks, Paul, for describing the actual behavior I’m seeing. I couldn’t find this documented anywhere, so posted here for confirmation.

The behavior makes sense, I guess, because even 95% of a very long note is, indeed, considerably shortened. But it would be great to document this as I spent several hours trying to understand what I was seeing (whole notes and quarter notes behaving quite differently).

I appreciate the response, but this is not what I’m doing. I’m writing a whole note and expecting it to be shortened to 95%, not 98.75%.

I realised that this behaviour was never documented, so I’ve mentioned this to Lillie who hopefully will be able to add this to a future version of the manual.


Then it really should not be displayed as a percentage. A percentage of a crotchet is not a useful unit if the meter is not in crotchets (and awkward even if it is).

1 Like

In which case I am trying to think how I would express the change. Putting it in absolute fractions of a second would not survive a tempo change.