Questions about VST and CPU performance and Computer stuff

Hello all.
First time here on the Steinberg forums :blush:

I’ll try not to bog you down with all my computer setup problems (those are documented very well on a home recording forum :p) and just pick up where I’m at now.

PC: HP desktop, Win 7 Enterprise. 64 bit. recently upgraded to 16GB RAM and AMD Phenom II X4 CPU. and that’s where the problems began. Eventually they led to me giving the computer to a tech friend to do a service on. All seemed well, but I felt like there is too much strain on my CPU considering what it is (Quad Core, 3.7 GHz). I originally thought that when I saw the CPU running at a higher percentage in Advanced System Care 4 then I thought it should be. Then I really started thinking that when I saw the VST ASIO Performance meter living between the 3rd and 5th bars (which I assume is 30-50%) when I opened up any sort of virtual instrument track. Before (before the tech friend set it up that is) I don’t recall ever seeing it go beyond the 3rd bar.

Also more concerning is that a couple of times ( random start up occasions) my computer has flashed to a “CPU Fan Failed” screen and shut itself down within 5 seconds. But on the start up immediately after the fan failure screen it starts up fine. Now out of the 10 or so times that I’ve started up the computer since I’ve got it back that’s only happened twice, but still, I don’t think that’s a normal thing at all :confused: :cry:

Looking for:
fellow Cubase users’ opinions.
where your vst performance meter sits
wtf you think is going on with my cpu situation
and also on a side note, your latency times ?(I’ve got 1.xxx ms input latency … but 13 ms output latency :astonished: :astonished: … is the gap between in/out latency times usual? )

Sorry for being the forum n00b :mrgreen:

Thanks for reading

What’s the full name of the ASIO driver you have chosen? (hint: you don’t want to see the word “generic” in it)

It does sound like you may have a hardware issue, though odd that the fan is absent intermittently. Maybe a motherboard problem. You do want an automatic shutdown if the fan isn’t there…it could save your CPU from frying. Been there. It happens withing minutes without a fan.

Does the missing fan problem only happen on a cold boot (from stoppped) or does it ever happen as well on a reset?

How many samples do you have your latency set at (not milliseconds)? It would typically be a number like 64, 128, 256, 512, etc. Also, what interface or soundcard are you using?

Thanks for the reply.

Yeah, initially, when I first saw that weird levels, I checked the ASIO driver, and it indeed was set at the generic (it was right after I did the 64 bit install), so I set to to the driver for my interface, the Tascam US1800.

Now that I think about it, the only times I’ve seen the CPU Fan Failure crash has been when I do a cold boot that goes into a “Windows Automatic Update” screen. Though, I can’t remember if it happens in the middle of the update, or on the restart following the update.
For what it’s worth though I have both restarted and cold booted the system successfully the other times.

The US1800 control panel is set to ‘lowest latency’ so I’m not sure what the rate is.
96kHz samplerate.

I have a laptop with an i5 and 4GB RAM that I run with C6 and a US008. I haven’t really seen ASIO spikes, and I believe the in and out latency times are both equal at whatever settings I have. I’m currently running 192/96kHz on there at 2.xxx ms latency.

you’re running 192KHz on your laptop?

No :stuck_out_tongue:, 96kHz.
The latency setting for my laptop interface is set to 192.

Are you using those samplerates for a specific reason? If not, 44100 will do just fine and save you a lot of unnecessary CPU load.

just latency reasons really.

:facepalm: I just thought that 96kHz is what drove my ASIO meter up, but went and moved to 44.1khz and the meter stayed the same.

Oh, I see where you went wrong. Fizbin said to check your latency in samples, but that’s not the same as samplerate :slight_smile:
Latency or buffer size (both are the same thing) is the ‘extra time’ you allow your audio interface to process the sound. So the question remains, what is your latency set at? You should be able to find and adjust this in the driver control panel. Experiment with lower and higher settings to see if it makes much of a difference on your asio load.

:stuck_out_tongue: sorry.

On my laptop US800 control panel, the latency tab has options in numbers (ex: 192-512). I’ve got it set to 192 on there.

The latency tab on the desktop interface(US1800) control panel however, which is the problem computer (at the moment at least :laughing:), only has “word options” (highest, high, normal, lower, and lowest latency).
Is that what you mean by latency samples :confused: ?
If so, changing those didn’t seem to make a difference on the ASIO load.
If not, is the anyway I can check the latency sample numbers in Cubase itself since the interface control panels runs inside Cubase?



Also on topic: I spoke with the tech guy today. He managed to clear a few things up, and mentioned that as long as nothing is actually running slow I don’t really have anything to worry about.

He’s not DAW familiar, but I told him about the ASIO meter, and the CPU failure screens and that
I had done some research on my own about how i feel my cpu isn’t running what it should be and found something about high temperatures limiting the processor so it won’t fry. So i checked my temps. Told him my temps (55 C when completely idle, 66 C the minute I open Cubase). And he said “Ahhhh. Looks like you need to upgrade your CPU fan. The one AMD included was probably meant as a basically bare minimum base fan for people building their own PCs.” Went on to say that will take care of me. And since the PC isn’t actually running slow and that there seems to just be more strain on it than it should have that it’s the fan not living up.
I trust the guy, it’ is what he does after all, so I’m going to upgrade that fan within a week or two.

What do you guys think?

I think you should try 44.1KHz at a slightly higher buffer size or Normal/lower. Also can you try turning Hyper Threading Off.

Have you enabled Steinbergs Power Scheme?

Alright, I’ll run through the settings tomorrow.
I would think with my new specs and since I’m running 64bit my computer would be able to handle whatever. :blush: Especially since my old specs never ran hot :frowning:

Hyper Threading? I’ve loosely heard of it… the intel thing?

I haven’t enabled Steinbergs Power Scheme, as I’m not sure what it does. I just sort of assumed since it was off on default it was better at that :confused:
Although, I have set my computer power settings properly. High performance, never/never, etc.; turned off system sounds.

Hyperthreading is irrelevant, that’s indeed for Intel CPU’s and yours is from AMD.
However, your ‘techy’ may be onto something. AMD CPU’s have ‘cool n quiet’, which means they CPU and fan speeds vary based on load and temperature. That means that your CPU gets throttled when temperatures rise.

A good fan certainly can’t hurt, and shouldn’t be very expensive. Check what socket your CPU is on and find a corresponding fan based on some reviews. If you are replacing it yourself, don’t forget to buy some Arctic Silver 5!

Oh yeah its an AMD chip!

They seem to have 4 power switching features that may get in the way ?

AMD Turbo CORE Technology
AMD PowerNow!™ Technology (Cool’n’Quiet™ Technology)
AMD CoolCore™ Technology
Dual Dynamic Power Management™

http://www.amd.com/us/products/desktop/processors/phenom-ii/Pages/phenom-ii-key-architectural-features.aspx

The pros and cons for these technologies and impacts on DAW performance are unknown to me
but maybe someone who knows could chip (intentional pun) in :laughing:

My CPU is a tad older than yours, so I’m not familiar with all the mumbojumbo technologies Split just posted, but I do know that CoolnQuiet should be disabled for high performance tasks. You can disable it from the BIOS.

I’ve got some CoolerMaster! :smiley: How’s that? :stuck_out_tongue:

When I first started googling, I came across this- http://gcoupe.wordpress.com/2011/04/13/vst-and-asio-performance-in-cubase-6/
which does sound really close to my situation. Although that guy didn’t have any fan failure problems… which is the only thing that really makes my situation different.
I went into the BIOS and didn’t see a “CoolNQuiet” enable/disable option. But my processor box does say “CoolNQuiet 3.0 Technology”.

BTW, for what it’s worth, my laptop has an i5. So if disabling hyperthreading is needed on there, how would I do that?

I don’t think the i5 processor has hyper threading.

Indeed, just the I7 and old Pentium models.

Hey guys.

Well, I’ve installed a new fan. Cooler Master Hyper. High performance Cooler Master thermal paste that I bought separately as well.

It’s had 8 boot ups (I did about the same or more on it with the old fan before I decided to change it). Four cold boots, and four restarts. All went fine. Yeah, I know, those are only 8 boots out of many many many many many more I need to have through it’s lifetime. So I suppose that the “CPU fan failure screen case” can never really be closed. Only time will tell nervous/scared face

My temps were at 30-40 C. whereas previously I was running 55 C (with nothing open :astonished: ) to 65 C.
Though I will point out that the side panel was off and it is a bit colder outside today. Though I dont feel like either of those would justify a 20-30 degree drop. Idk though.

I messed around- on google, opened up Cubase 32 and 64 bit. (44.1 and 96 kHz in each.)
Opened a synth(… Prologue, I believe) just to check out the VST meter… it was fine :smiley:

…but then I opened up a stock Maschine project (again, both 32/64 bit and 44.1/96 kHz)… the VST meter shot straight to the halfway point (and that red light thing was “clipping” occasionally) :cry: … And now that I think about it. The same does happen to the meter when I open Maschine on my laptop too. Idk why… in the past it wouldn’t. (I could open Maschine multiple times with NO spikes on the VST meter.)
Now, I should point out that nothing is freezing or crashing on me. I just don’t understand why the ASIO meter is spiking like it is now. It doesnt make sense. Didnt happen in the past. With Le5 or with 6.


So I guess that would make my VST meter problem with Maschine/Cubase.
I’ve got all the Maschine updates installed. So I don’t know what else to do.

A few people have suggested cool n quiet could be the problem.
I don’t know how to turn off Cool N quiet. I dont see anything for it in the BIOS. I’ve set my power scheme to High Performance, and the min/max processor states to 100%. There also is a “system cooling policy” tab which is set to passive.


Also, the latency times still look weird, but to be honest, I don’t notice a delay. I suppose that’s all that really matters :confused:


//

Although not really important, you might actually get even lower temperatures when you put the side back on. The airflow in your case will be better then, provided your case has adequately placed fans.

Native Instruments plugins are known to be rather heavy on the CPU, but you should really not have the issues you describe with Maschine. I know there was a similar problem with Reaktor about a year ago, where you had to change the audio priority in your Cubase settings to ‘the other one’. If on boost, ucheck it, if on normal, check it. That got fixed by NI with a patch though, so I can’t imagine they got the same problem in Maschine now.

Worth a shot anyway :wink:

Thanks for the suggestion (well… both of them actually), I’ll do that once I wake up :smiley:
It’s 7 am now. I’ve been at this computer stuff all night!

I’ve came across a few ASIO youtube video where they suggest the bug is with Cubase. But I don’t know if I have any reason to feel that way. Only seems to spike with Maschine comes in. Whether it’s by itself or with other tracks. I can have a number or other tracks running no prob.

I’ll also check out my laptop tomorrow as well. I’ll open maschine (and even komplete elements) on there to see if maybe it is the Native Instruments stuff (which I could see being the case.). I mean it’s a completely different computer with completely different specs and a different interface… so if I have the same problems on there ONLY when I open up N.I. stuff maybe I’ll need to get some help from the folks at Native themselves

I love their stuff, but they certainly have known issues. I just bought Komplete 8 Ultimate (which Im waiting to get this stuff sorted out before I install) and it’s shipped with a few defective hard drives… knowing my luck I hope and pray I dont end up with one of those :open_mouth:
really hope I get it sorted out. I upgraded everything hoping not to have to deal with problems from CPU heavy things.
i just want to make music!!! :cry: