Questions: playback, system spacing, importing, master pages

I think I’m nearly on top of everything I need to know about what I can do with Dorico and what its capabilities are. But in the words of Columbo, there’s just one more thing…

  1. Can I import separate MIDI or XML files into different flows of the same document? It doesn’t seem like it: I’m hoping this is on the roadmap.

  2. The Playback cursor scrolls, but the window doesn’t follow it. I have the setting “Follow Playback” in Preference turned ON.

  3. I have one piece where, when I delete a staff, the staves respace wider to fill the page. Nice. But I have another document where that doesn’t seem to be happening: there’s a huge gap in the middle of the page between the two systems. Do I have to manually increase the flow margins in Setup? Are thereany other settings for these functions, and where are they to be found?

  4. How can I save a default master page for all new documents? Or indeed, have a “library” of different masters for use in different projects?

  1. It is on the roadmap

  2. Known problem, you have to follow manually. On the roadmap too

  3. In layout option, note spacing, untick Justify last system… or change the percentage

Thanks, Marc.

For 3, I’m talking bout vertical spacing of staves within a system, and the gaps between systems.

  1. Also planned. Best at the moment is to create the masters then start a new document from that document. You can actually have this ‘Template’ document without any players or music in it.

At the moment, this preference only applies in Play mode, not in Write mode.

I suspect that what’s happening here is that the systems are falling between the two thresholds defined for vertical justification, which you can find on the Vertical Spacing page of Layout Options. When the page is more than 80% full but less than 100% full, Dorico will only justify the gaps between systems (assuming there is more than one system per page), but when the page is more than 60% full but less than 80% full, Dorico will also justify the gaps between staves as well. You should be able to get the results you want by fiddling with these thresholds, sometimes only by one or two percentage points.

for #3. Before you go through hoops, try exiting Dorico and the re-opening Dorico and loading your file. I’ve noticed that on occasion doing that prompts the system to recast widely-spaced systems into more conventional spacing. (No idea why–still, the look improved without my doing anything more than exiting the program and re-opening.)

Try Derrek’s method. And anyway, you could experiment the layout options (gap between systems), I tried it and it pleased me, it’s been my automatic way of filling pages in parts without manual interference.