Quick control set up with Track Instruments?

It seems quick controls don’t work, or they work differently when using track instruments.

I want to use an external hardware controller to turn on/off a send, and also to control the send volume.

With rack instruments it seems straight forward. First make sure everything is properly set up in the Device Set Up>remote Devices>track quick controls. I have set everything correctly, and it works perfect with using rack instruments.

Example: Select Kontakt and enable 3 outputs.

  1. select Kt St 1 in the mix console.
  2. select a send, for example, fx1.
  3. go to the inspector, select quick controls
  4. activate quick controls
  5. click in the first box and select sends
  6. click the little “+” sign then “1” since this is the first send slot.
  7. select enable
  8. click the second box under quick controls
  9. click the little “+” sign then “1” since this is still the first send slot.
  10. but this time select “level” instead of enable.

Now my hardware controller can turn a send on, and adjust the level.

But, this doesn’t work the same with Track Instruments. In Track Instruments you can select Kt St1 in the mix console and go through the above 10 steps. But when you select Kt St2, the second Kontakt channel, and then want to set up and control a send by repeating the above 10 steps, it doesn’t seem to work.

Help?

Hi,

I can enable the Level of the Send by using an Instrument Track.

Please by aware, the Kt.st.1 output is already unfolded, in the QCs parameters slot. Click to - to Pack everything, then open Sends > Level.

Yes, I think I can do exactly what you said. It’s identical to my 10 steps above correct? With Track Instruments, this works for the first Kontakt channel I set up, but not any additional channels. Click on Kt. st2, assign that channel a send, (always the first slot) and attempt to do exactly what you did with channel 1. I can’t get this to work.

You said Kt. st.1 is already unfolded in the QC parameters slot. Are you referring to clicking on Kontakt then a list of cc’s from 000 to 511" if using the full Kontakt?

With Track Instruments, when I switch to Kontakt channel 2 in the mix console, then repeat what I think you just described above, I don’t get a blank or “clean slate” in the Inspector>quick controls box. The send level parameter, and the enable/disable parameter stays the same in channel 2 as it was in channel 1. When you switch Kontakt channel tracks, either in the mix console or the project page, the Inspector>sends should reflect those changes just like it does when using Rack Instruments. Therefore, I can’t figure out how to set up my quick control send level, and enable/disable, for channel 2 because it hasn’t changed to a blank or “clean slate.”

When I load Kontakt as a Rack Instrument, then enable multiple outputs, I add a send to channel 1, and add a send to channel 2. Now, make sure Channel 1 is selected. Then I go to the inspector, click on quick controls. Click on the top box that pulls down the menu, click “sends” then click the “+” by the number 1, which will open up “enable” “level” and “+ standard panner.” I select “enable” for sends 1. Then go back, and in the 2nd box, click on “sends” then “+” by the number 1, then “level.” I now have control of activating the sends enable/disable plus control of the send level from my hardware controller.

Then when I want to do the same for Kontakt channel 2, I click on channel 2, and the Inspector reflects that change with a blank or “clean slate.” I can repeat this process for channel 2 with success. But if I had clicked on channel 2 with Track Instruments, the Inspector doesn’t change to a blank or clean slate. With Track Instruments when I click on Kontakt channel 2, the send enable/disable, and send send level, are exactly what was in Kontakt Channel 1.

I’m probably don’t something obviously screwy, but I can’t figure this out.

I can send a screen shot of Devices> Device Set up>remote devices>track quick controls if it’s necessary.

PS Thanks for your help in this forum! Your contributions greatly help out.

Please, could you send a screenshot of Instrument Rack (where it works), and the same place of Instrument Track?

Here are 3 screen shots.

Instrument Rack is working. Using Kontakt, I go through my 10 steps and everything is set up for Kt st1. Then I click on Ktst2 and repeat the 10 steps and everything is set up for Kt st2. Everything is good.

Instrument Tracks channel 1 is working. I go through my 10 steps and everything is set up for EZ Drummer “kick.” So far so good.

But when I click on Instrument Tracks channel 2 “snare”…I cant figure out how to set that up with Quick Controls. As you see, when I click on channel 2 “snare”, the identical send information in quick controls reflects send 1-enable=on, and send 1-level -16.3…which is the same as channel 1! If this were a Instrument RACK, this Quick control would be blank and I could go through my 10 steps setting it up.

I can click on any Instrument Track audio out, (“kick” through “EZ16”) and nothing changes in the Inspector Quick controls. No matter which audio out I click on, the Quick control shows Sends 1 Enable ON, and Sends 1 Level at -16.3. I would think this quick control should change depending on the track selected…assuming you have set the quick controls up and they are not blank.

If I were in Rack Instruments, and click on any subsequent channel like Kt St2-Kt St4, I will get a blank quick control where I can set up my send enable and my send level.

Apologies for not making this more clear. clck on Instrument Rack first, then Track Instruments, and then Instrument tracks track 2…can’t set up quick controls.
Instrument tracks track 2..can't set up quicki controls.png
Track Instruments track 1 selected.png
Instrument rack.png

Here is a shot of my Device set-up.

Again thank you for your help!
device set up.png

Hi,

I see, I got your point, now.

The problem is, the Quick Controls refer to the Instrument track itself in the Project window. Not to the Audio Return. So in the Project window, you can see just the Quick Controls assigned to the Main (default) Audio Return (Kt st.1 in case of NI Kontakt).

But, if you open MixConsole, and enable QuickControls in the Racks, you can define your QuickControls for the dedicated Audio Return Channels. Then it works as expected. So every single channel has its own Send Level, which you can control via the Quick Control.

The result (moving slider) is visible in the Quick Controls of the MixConsole, not in the Project window, then.

Thank you. I understand. I have never even set up quick controls from the mix console. The advantage I see doing this in the mix console is that it will work with both Track Instruments and Rack Instruments. Consistency is a good thing.

Unfortunately, as shown, you can’t have this consistency on the project page with the inspector because you can only set up sends for Rack Instruments. This added much confusion.

Someday I hope Steinberg achieves 100% consistency, meaning what you do in either the project page or the mix console will be reflected in the other.